
 

 

CHAPTER 1 - INTRODUCTION TO WEB STUDIO 4.0 
 

Welcome 
Welcome to Web Studio!  We are very pleased to introduce to you a programming innovation in 
the world of Web site construction and design.  Gone are the days of clunky, hard to use HTML 
editors and overpaid “Web consultants”.   
 
With Web Studio you can drag and drop your way to a professional Web site.  The process is 
quick, easy, and enables you total design satisfaction.    
 
Today, thousands of small businesses, organizations, universities, schools, and individuals are 
using Web Studio to create their websites.  We are certain you’ll also find Web Studio is an 
invaluable addition to your software library.  

Web Studio Makes Building Web Sites Easy! 
Web Studio is a Web page and Web Site building program.  It enables you to design your pages 
visually by placing images and text on your pages using your mouse to drag and drop.   

The program includes fourteen design galleries that contain graphics, sounds, links, Special F/X, 
and much more.  You can easily incorporate your own photos and graphics into your pages with 
Web Studio.  With a simple click of the mouse Web Studio creates the HTML for you and will save 
your pages on the Internet where they can be viewed by anyone with an Internet connection.   

You do not need technical training or computer programming knowledge to use Web Studio.  If 
you can use a mouse you can make great Web pages!  Web Studio includes contemporary 
graphics, sounds, and Special F/X to choose from and many templates to help you get going in a 
hurry!    

Web Studio’s Philosophy 
Web Studio was designed for the non-technical person who wants to create an awesome web 
site.  It was designed to hide the complexities that exist in web pages and their authoring. It also 
hides many of the limitations of web pages. The language used to write web pages, HTML, has 
many limitations that people who use today’s modern software wouldn’t really like. Web Studio 
hides many of those limitations and takes great pains to make your pages look exactly like you 
designed them when they are on the web. The pros use very expensive software from Adobe, 
Macromedia and others to get around the limitations of HTML, Web Studio takes care of all that 
for you and you don’t even know it happened. 
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Web Studio is also designed so that you have everything you need to create great looking web 
sites without having to go back and buy additional software. The Special FX Gallery is a great 
example of this. The pros use a graphic technique called Drop Shadows to make page elements 
look like they are floating above the other things on the page. Drop Shadows require an 
advanced graphics program to make and are difficult to do. Web Studio enables you to add drop 
shadows to your text and graphics by simply dropping the effect onto your text or graphic. 

The content in Web Studio is included to complete the “all-in-one” approach. You won’t have to 
buy a collection of web art to make your page when you start with Web Studio, the collection is 
already integrated into Web Studio’s galleries and the WebStudio.com web site’s Content Gallery. 

And then there is the task of actually getting your web pages to the web! Web Studio includes 
everything you need to do that as well. And it is also fully integrated into the program. If you use 
Web Studio’s iHostStudio web site hosting, saving your pages to the web is easier than saving a 
file to your hard disk! If you already subscribe to a hosting company, saving your pages to the 
web is still just a click away and you don’t have to know anything about how the files get there, 
how they are managed, arranged or stored. 

Having said all of that, Web Studio has a lot to offer the advanced, technically savvy person as 
well. Web Studio enables the advanced user to program his own HTML, Java and Javascript, ASP, 
PHP, and other web technologies and add it to the pages Web Studio creates.  For the advanced 
user, Web Studio’s simple drag-and-drop approach to building pages enables them to quickly get 
the visual design they want and then write their advanced HTML to really bring their pages alive.  

So, in a nutshell…Web Studio exists to let anyone create a great web site by including all the 
things necessary to do the job well while hiding the complexities and programming required with 
other software products. 

 The Official Web Studio Website  
Be sure to visit us at the Official Web Studio Website found on the Internet at 
http://www.webstudio.com.  (You can also get to us quickly from within Web Studio by using the 
drop down Help menu and selecting Official Web Studio Website!)  Here you can find many great 
resources to enhance Web Studio.  It will also inspire, inform, and expand your abilities as a Web 
page builder.  Here are a few of the reasons to visit! 

Web Studio Content: Web Studio 4.0 includes a basic set of content in its Galleries. The 
WebStudio.com Content Gallery contains tens of thousands of additional pieces of content for 
Web Studio. Why isn’t it all included in the Web Studio 4.0 product? Two reasons, first it would 
take forever to download all of the art, it is hundreds of megabytes of content. Secondly, you 
may not want it all.  With the web site’s Content Gallery, you can browse through all of the 
content collections to pick and choose the content you want to add to Web Studio.  

Once you pick a content collection to download from the web site, it will download and install 
itself into Web Studio 4.0 automatically. It will appear in the Gallery next time that gallery is 
used. And, it is free! 
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Web Studio Tutorials: These are online, animated tutorials to illustrate exactly how to perform 
various tasks with Web Studio. The Tutorials consist of a suite of tutorials that will guide you 
through all of the basics of using Web Studio. The Tutorials also offer tips on getting the most 
out of Web Studio which are not to be missed.  

The Web Studio Forum: The Web Studio message board, the Forum, is a great place to meet 
other Web page builders using Web Studio, but more importantly it is a great place to go for 
advice, tips and tricks, and for free comments about your site!  Let our Forum moderators and 
other Web Studio power users help you with great ideas on how you can get the most out of 
your Web pages.  From learning the basics to getting tips on the latest cool effects the Web 
Studio Forum should be in your "Favorite Places to Go" list! The quickest way to get there is by 
choosing Help>Web Studio On-Line Forum in Web Studio. 

Web Studio FAQ: If you have a question about something related to Web Studio, there is a 
good chance someone else had the same question!  So, head to the Web Studio FAQ (Frequently 
Asked Questions) page and you will probably learn more than what you were looking for! The 
quickest way to get there is by choosing Help>Web Studio On-Line FAQs. 

Web Studio Technical Support: Back To The Beach's Technical Support is hard at work 
finding solutions to your Web page building problems.  Some are common, and some are unique.  
Check out the Resources page and you are bound to find a solution to your problem. Make sure 
you check out the Forum. They have the answers to most of the questions ever asked about Web 
Studio and best of all the web site is available 24 hours a day, 7 days a week, so it is ready when 
you are. 

We also offer support via email with quick turnaround and live telephone support. Check the 
Customer Support page for hours of operation. 

Web Studio Monthly Newsletter: The Web Studio Newsletter is packed full of information 
enabling you to get the most out of Web Studio. Published monthly it contains a feature article 
written by a Web Studio expert, tips and techniques, little known features, the HTML corner for 
those who want to delve into more advanced topics and much, much, more. The Newsletters go 
out monthly to all registered Web Studio owners. The Web Studio Resources page has an archive 
of all previously published Newsletters. They make great reading. 

About This Manual 
The manual covers all you need to know for using Web Studio.  Whether you are a first time user 
or an experienced Web site designer, this manual will provide you with definitions, suggestions, 
and all around resources for getting the most out of the program.   

We placed a great deal of energy into creating a good manual for Web Studio.  However, if we 
included everything you can do in the manual it would be enormous. The manual gives you an 
introduction to the program’s capabilities and all of its commands. It also includes some tips and 
techniques on how to use its capabilities to get advanced results. 
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The manual is just one part of the Web Studio documentation suite, however. The program’s 
Help menu and the WebStudio.com web site are great resources as well.  The Help menu will 
quickly give you the information you need without having to go back to the manual all the time.  

The WebStudio.com web site has expanded FAQ’s, animated tutorials, articles, newsletters, and 
the Web Studio On-Line Forum where our Web Studio experts will help you with anything Web 
Studio. 

To learn how to Install Web Studio 

Go to chapter 2, Installing Web Studio 4.0 to learn how to install and register Web Studio. 

For an introduction to Web Sites 

Go to chapter 3, Web Site Concepts which introduces you to what a web site is and the 
conceptual differences between websites and word processing. 

For an introduction to Web Studio 

Start with Chapter 4, Getting Started introduces you to the concepts and features of WebStudio 
and takes you through a short tutorial. This tutorial shows you how to use the program to create 
a simple website, to preview your work, and how to upload it to the internet.  

Detailed information about the Content Galleries 

Chapter 5, Working With The Galleries describes everything you can do with the galleries and 
how to do it. 

Detailed information about Objects 

Chapter 6, Working With Objects describes the operations and command you can use on any 
object on a Web Studio page.  

Chapters 7 through 17 detail all of the operations and commands that are specific to each type of 
object in Web Studio. 

Chapter 19 describes the Property dialogs in Web Studio used to change the settings of individual 
objects, of pages, and of the entire website. 

Detailed information about using Links 

Chapter 18 describes links and how to use them in Web Studio. 

Detailed information about using Frames 

Chapter 20 describes Frames and how to use them. It also includes a short tutorial on using 
Frames. 

Detailed information about Menus and Toolbars 

Chapters 21 through 23 describe all of the menu commands and tool bar commands in Web 
Studio as well as keyboard shortcuts. 
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Detailed information about using the Web Studio/iHostStudio Shopping Cart 

Chapter 26 describes how to set up and use the Web Studio/iHostStudio Shopping Cart that is 
included in all business hosting plans with iHostStudio. 

Printing, Previewing and Uploading Websites 

Chapters 25 and 27 describe how to print pages, preview your site or any page in a site, as well 
how to upload a page or a site. You are also introduced to our optional iHostStudio integrated 
website hosting service. 

Advanced Usage of Web Studio 

Chapter 28 describes how to add your own HTML or other advanced technologies to objects, 
pages, and your site.  

Conventions used in this manual 

Words in italic type refer to actual user interface elements in Web Studio. Commands, text in 
dialog boxes, etc., are in italic type. 

Menu commands are shown in italic type and include the Menu name and command name 
separated by a greater-than-character, “>”. For example, Edit>Undo refers to the Undo 
command in the Edit menu. Menu commands in hierarchical menus are similar, for example: 
View>Highlight Objects>With Links.  

Web Studio Specifications 

Minimum System Requirements 
Microsoft Windows 98SE, ME, 2000, XP, 2003 

CD-ROM or DVD Drive 

40 MB hard disk space for program installation 

Windows-compatible sound card 

Pentium II microprocessor or better 

128 MB Ram 

16-bit color display 

Microsoft Internet Explorer 5.5 or later 

Recommended System Requirements 
Microsoft Windows 2000, XP, 2003 

CD-ROM or DVD Drive 

40 MB hard disk space for program installation 
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Windows-compatible sound card 

Pentium 4 microprocessor or better 

384 MB Ram 

32-bit color display 

Microsoft Internet Explorer 6.0 or later 

Maximum Number of Pages 
No limit, limited by Memory 

Practical Limit: 60 pages, split larger sites into multiple Projects 

Maximum Page Length 
Limited to 32767 pixels, or approximately 47 pages of text per page. 

Practical Limit: limited by memory, Windows swap file size, processor speed 

Recommended Limit: 10,000 pixels, or approximately 14 pages of text per page. 

5,000 with Windows 98 and ME, or approximately 7 pages of text per page. 

Operating Recommendations 
Web Studio is a very resource and memory intensive program. This is due to the nature 
of its visual editing, and the nature of the content you add. A graphics program like 
Adobe Photoshop has the ability to handle very large pictures. However, it usually is 
handling one or two large pictures at a time. Web Studio is tasked with handling as many 
large pictures per page as you desire, and to handle many pages of large pictures.  

An actual customer’s website, a photographers site, contained 50 high resolution pictures 
per page. Each was 1600 X 1200 pixels in size, which results in 7.6MB per picture. The 
pictures are on the page as Thumbnails which enables many pictures per page since they 
take up very little room on the page. The memory require for Web Studio to open and 
use the page is 384 MB. The memory required to handle 10 pages like this is 3.8 GB, 
more memory than most computers can physically use. 

Keep a minimum number of pages open at any time. Each page uses memory and 
resource. 

Limit page length to recommended values, longer pages use more memory and 
resources.  

Keep the size of graphics as small as your page design allows. Using thumbnails does not 
lower memory requirements when using Web Studio, but they do lower the size of the 
page on the web. 
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HTML Type Generated 
HTML 4.01 Transitional 

HTML 4.0 Frameset 

Graphics Files Imported 
Graphic Interchange Format (.gif) 

JPEG (.jpg) 

Windows Bitmaps (.bmp;.dib) 

Photoshop  (.psd) 

PCX (.pcx;.dcx) 

Kodak Photo CD (.pcd;.fpx) 

Portable Network Graphics (.png) 

Encapsulated Postscript or EPS (.eps) 

Lead Tools (.cmp) 

Tagged Image File Format or TIFF (.tif) 

Icons & Cursors (.ico;.cur) 

DICOM (.dic) 

Windows Metafile (.wmf) 

Truevision TARGA (.tga) 

SUN Raster (.ras) 

WordPerfect (.wpg) 

Macintosh PICT (.pct) 

Video Files Imported 
Windows Media Video(.wmv) 

Audio Video Interleave (.avi) 

MPEG video (.mpe), (.mpg) 

Real Media (.rm), (.ram) 

MS NetShow Player (.asf), (.asx) 

Quicktime Movie (.moov). (.mov). (.movie). (.qt) 

Sound and Music Files Imported 
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MP3 File (.mp3) 

MIDI (.mid), (.midi) 

Windows Media Player (.wma) 

Real Player (.ram), (.rm), (.ra) 

Wave (.wav) 

AIFF (.aif), (.aiff), (.aifc) 

Sun Audio (.au) 

MPEG-1 (.m1a) 

MP2 (.mp2) 

Windows Media Playlist (.w3u) 

Text Files Imported 
Text (.txt) 

Rich Text Format (.rtf) 

Microsoft Word (.doc) 

HTML (.html) (.htm) 

HTML Document (.htx, .otm) 

Text With Layout (.ans) 

MS-DOS Text with Layout (.asc) 

Expandable to include any file type from the Microsoft Office Converter Pack (available as 
a download from the Microsoft Website). For example: 

Microsoft PowerPoint 

Microsoft Excel 

Microsoft Works 

Microsoft Word 4.0 and 5.0 for Macintosh 

Lotus Ami Pro 

Word Perfect 

Word Star 

HTML and Scripting Files Imported and Exported 
Text (.txt) 

Hypertext (.htm) 
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Hypertext (.html) 

Hypertext (.shtml) 

Hypertext (.xhtml) 

Hypertext Template (.htt) 

Javascript (.js) 

Javascript (.scpt) 

Cascading Style Sheet (.css) 

Server side include (.ssi) 

Internet Database HTML Ext (.htx) 

Active Server Page (.asp) 

Active Server Application (.asa) 

PHP Server Page (.php) 

PHP Server Page (.php3) 

Common Gateway Script (.cgi) 

Perl Script (.perl) 

Perl Script (.pl) 

Perl Module (.pm) 

Extended Markup Language (.xml) 

Document Type Definition (.dtd) 

Wireless Hypertext (.wml) 

SMIL (.smil) 

Files to be Downloaded from WebSites 
Any file, no limits 

 

 

 


