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 CHAPTER 8 - BUTTONS 
 

Overview of Buttons  

 

Buttons can take your visitor to a different location on the current page (aka “anchor”), to 
another Web page on your site, or to another Web site on the Internet.  Choose a button’s visual 
style that fits the theme of the page itself.  Match a science fiction Web page with science fiction 
style buttons.  

Buttons and Links 
In order for your buttons to actually take your visitors to another page on your site or another 
site altogether, you have to add one additional secret ingredient…a link. 

A link is simply the web address of another web page, either yours or someone else’s. You click 
on a button with a link and your browser takes you to the page represented by that 
address…kind of a cyber taxi-cab. 

The buttons in Web Studio’s Button Gallery don’t come with links, you add them yourself after 
you’ve placed the button on your page. You do this with the Links Gallery. The Links Gallery has 
all of the links will need to link your site together in its Site Links lists. For links to other websites, 
you can easily create them with the Links Gallery’s MyLinks list. 

For more information about linking, see the section in this chapter on the Links Gallery. 

Smart Buttons  
You’ll notice there are many different buttons and styles of buttons in the button gallery. The first 
eight buttons, however, are different; they are “smart” and can change how they look for you. 
Dragging one of these enables you to add a button of the chosen style with any color you 
choose.  
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The styles are square edged, coved, rounded with both filled color and just outlined with color as 
well as the 3-D button 

To create a smart button, simply drag and drop the style of your choice. The Windows Color 
Dialog will appear. 

 

Choose a color from the dialog. The button will be placed where you dropped it. You can then 
resize the buttons to whatever size you need. 

Rollover Buttons  
A Rollover Button changes how its looks when a mouse is over it and when it is pressed. Rollover 
Buttons have three “states”: normal, over, and down. When one of these buttons is viewed in a 
browser it looks as it does on the Web Studio page. When the mouse is passed over top of it, it 
changes to the over state (state is a fancy name for look or design). When the mouse is pressed 
on the button, it changes to its down state.  

 
Rollover with its three states: normal, over, and down. 

To make a Rollover, simply drag the Rollover Smart button onto your page. First you’ll see the 
Windows Color dialog. Choose the color you’d like for your button and press OK. Then the 
Rollover Studio dialog appears.  
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In this studio, you can add text to the button, and also change the font, style and color of the 
text as well. You can then change the hue (fancy word for color) of the Over and Down buttons.  

Note: Once you have created a Rollover Button and it is on your page, you can double click on it 
at any time to return to the Rollover Studio. This enables you to change its text, font, color or the 
hues used for the over and down states (you get to change your mind!). 

Note 2: This also implies that you can create an entire family of buttons with the same look and 
color by creating one and then duplicating it and changing the text as appropriate (you get 
increased productivity!).  

 

Graphic Buttons  
Graphic Buttons are simply that, graphics that look like buttons. To use them you simply drag 
one onto your page. They don’t change themselves, don’t have text (unless the button you 
choose already does), they are simply graphics that look like buttons.  

Rollover and Smart Buttons and Graphic Buttons 
If you want to create a Rollover style button out of one of the smart buttons or any other button 
in the Button Gallery, simply hold down the ‘ALT’ key when you drag the button onto your page. 
After that, the process is the same as creating a Rollover from the Rollover Smart Button.  

 

Here’s a coved smart button that is now a Coved, Smart, Rollover Button. 
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Tip: This enables you to add text to any Graphic button as well as change their colors. 

Graphic Rollover Buttons  
The final type of button is the Graphic Rollover button. It consists of three different graphics that 
make up its normal, up and down states. To create one of these you must add three graphics (or 
text objects) to your page. They can be anything you like, but they should share the same 
proportions since Web Studio will scale them to the same size as the “normal” state graphic. 
Once you have three graphics on your page select them in the order you want them to appear—
normal, over and down. (Remember to hold the shift key down while you select all three.) Web 
Studio uses the order you select them to determine which is the normal, over and down graphics. 

Once the graphics are selected, drag the Rollover Button Maker onto any of the graphics. 

 
Rollover Button Maker 

 

The Graphic Rollover Studio dialog will appear. 

 

 

This dialog is similar to the previous Rollover Button Studio but it enables you to change not only 
the text, font and color, but also the actual graphic used for the over and down states.  

Note: You don’t have to add text to any of the rollover buttons. This is especially true with the 
graphic rollovers since they may already have graphic content that indicates their state and 
purpose in life. 

Note: you can use graphics or text objects to make Graphic Rollover Buttons. You don’t have to 
use 3 graphics or 3 text objects, it can be any combination of each. 
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Changing Your Rollover Buttons  
In addition to the Rollover Studio’s abilities, the Take Apart command in the Object menu lets 
you “take apart” your rollovers into their component parts. You select the rollover, then choose 
Take Apart. The individual graphics that make up the button will be placed on your page in the 
order they were in the button. The bottom graphic is first, the middle is the over and on top is 
the down graphic.  You can then change any of the button’s graphics, change the order, create 
and add new graphics.  

To re-create the rollover, select the graphics in the appropriate order and drop the Rollover make 
on to them. See the section titled Graphic Rollover Buttons for more information.  

Button Tips and Techniques 
• You can use the Rollover Studio to simplify the creation of all of the buttons for your web 

site. You don’t even have to use them as rollovers. The tip is that you can use the Studio 
to add editable text to your buttons. In previous versions of Web Studio, you’d have to 
create a text object, and merge it with a button graphic. Once you did that you no longer 
could change the text in the button (remember, you’d do this to make an entire family of 
buttons). With the Button Studio you can do this easily. 

• Easily create buttons with text in them. You don’t have to use the rollover feature of the 
buttons. If you leave the color of the over and down states the same as the normal 
state, they won’t appear to be rollovers on your web site. They will seem to be normal, 
run of the mill buttons. The same goes for the graphic buttons. You can use the Studio 
to add the editable text to a graphic button and use the same graphic for all three states. 

• You can use Graphic Rollover buttons using the same graphic for each state but with a 
different color hue. To do this simply drag the same graphic three times from the Button 
Gallery or copy and paste an existing one twice. In any event, get three copies of the 
same graphic on your page. Then drag the Photo Correction Wizard from the Special FX 
Gallery onto one of them. Page through the wizard until you come to the Hue page and 
change its hue. Do this to the third button using a different hue. Finally select the objects 
in the order you want them (normal, over and down) and drop the Rollover Button Maker 
onto any of them. 

• You can use Graphic Rollover buttons using the same graphic for each state but with  
different text. To do this simply drag the same graphic three times from the Button 
Gallery or copy and paste an existing one twice. In any event, get three copies of the 
same graphic on your page. Create three text objects using Insert>New Text Object. 
Enter the text you want for the normal button into one of the text objects. Move that 
object on top of one of the buttons. Resize it so that it fits within the button. Select both 
the graphic and the text object and choose Object>Merge Selected Objects. This 
combines the graphic button and the text into one object. Do this with the other two 
graphics. Finally select the objects in the order you want them (normal, over and down) 
and drop the Rollover Button Maker onto any of them. 
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• You can use the Graphic Rollover buttons to create cool rollover effects on your site. For 
example, a “moody” photography site with a black background (popular with photo sites) 
could have a “table of contents” made of very dark versions of photos. When the mouse 
passes over one of these photos the picture lightens to its normal value. When it is 
pressed, you could take the visitor to that section of the photo site with the appropriate 
link from the Link Gallery. To do this effect, simply add three copies of the same graphic 
to the page. Use the Photo Correction Wizard from the Special FX Gallery to darken the 
“normal” photo. Then select al three photos with the dark one selected first, and drop 
the Graphic Rollover Maker onto one of them. That’s it! 

Working with Buttons 
The buttons gallery is filled with a variety of graphic buttons, rollover buttons, and button 
makers. 

The first eight buttons are “smart” buttons. You can drag one of these to create a button of the 
style you choose and a color of your choice. 

The next button, isn’t a button, but the Rollover Button Maker. This enables you to create 
buttons from three individual graphics that will visually change when the mouse is over top of 
them and when the mouse button is pressed over them. 

The Smart buttons can be created as Rollover buttons as well. 

The remainder of the gallery consists of individual graphics and a sub-gallery of pre-made 
rollover buttons. Note that any of the graphic buttons can be created as Rollover buttons. 

Adding a button to a page: 

Choose the Button Gallery 

Find the button to be dropped on the page. 

Drag the button onto the page in the location it is to appear. 

Drop the button. 

The button is placed on the page. 

Using “Smart” buttons 
Adding a smart button is a two step process. 

To add a Smart button: 

Choose the Button Gallery 

Find the style of Smart button to be dropped on the page. 

Drag the button onto the page in the location it is to appear. 

Drop the button. 
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The Windows Color dialog comes up. Choose a color for the button and press OK. 

The button with the chosen style and color is placed on the page. 

Adding “Smart” buttons as Rollovers 
This type of Rollover button is known as a Hue based button. This type of button changes its hue 
or color when the mouse is over it or pressed on it. Adding a smart button as a Rollover is a 
three step process. 

To add a Smart button as a Rollover 

Choose the Button Gallery 

Find the style of Smart button to be dropped on the page. 

Press and hold down the ALT key on the keyboard. 

Drag the button onto the page in the location it is to appear. 

Drop the button. 

The Windows Color dialog comes up. Choose a color for the button and press OK. 

The Rollover Studio dialog comes up. Use the sliders to change the color of the “Over” and 
“Down” buttons. Enter any text into the button. Choose a font, style and size for the text. Choose 
a color for the text. Choose raised, flat, or sunken as the style for the text on the button. Press 
OK 

A Rollover button with the chosen style, text and color is placed on the page. 

Adding Graphic buttons as Rollover buttons 
The Button gallery contains many graphic buttons. All buttons that are not “Smart” buttons are 
graphic buttons. Also, any graphic can be used as a Rollover by adding it to the Button gallery 
and then following the following instructions. 

Creating a Rollover button from a graphic results in a Hue based button. This type of button 
changes its hue or color when the mouse is over it or pressed on it. Adding a graphic button as a 
Rollover is a three step process. 

To add a Graphic button as a Rollover: 

Choose the Button Gallery 

Find the button graphic to be dropped on the page. 

Press and hold down the ALT key on the keyboard. 

Drag the button onto the page in the location it is to appear. 

Drop the button. 
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The Rollover Studio dialog comes up. Use the sliders to change the color of the “Over” and 
“Down” buttons. Enter any text into the button. Choose a font, style and size for the text. Choose 
a color for the text. Press OK. 

A Rollover button with the chosen graphic, text, and over and down colors is placed on the page. 

Creating Graphic Rollover buttons 
The button gallery contains a Rollover Maker item that creates a Rollover from three individual 
graphics. These buttons are known as Graphic Rollovers. 

To create a Graphic Rollover button: 

Add three graphics to the page. One that represents the normal state of the button. One that 
represents the state when the mouse is over the button. One that represents the state of the 
button when the mouse is down over the button. 

Select the graphics with the Shift key pressed. Select the normal graphic first, then the over 
graphic, and then the down graphic. 

Drag the Rollover Button Maker onto any one of the selected graphics. 

The Graphic Rollover Studio dialog comes up. 

Enter any text to be added to the buttons. Choose a font, style and size for the text. Choose a 
color for the text. Press OK. 

A Graphic Rollover button is placed on the page. 

Note that the normal graphic’s size is used at the size of the button. If the other graphics are 
different sizes, they will be scaled to suit. 

Editing Hue Rollover buttons 
Editing a hue rollover enables changing the text, font, text color, or hues for the button. This is 
useful when creating a suite of buttons for a site. From the original button, copy and paste the 
number of buttons necessary and then edit the buttons to change the text to what is needed for 
the site. 

To change the hue or text in a hue rollover button: 

Double click on the hue rollover button. 

The Rollover Studio dialog comes up. Use the sliders to change the color of the “Over” and 
“Down” buttons. Enter any text into the button. Choose a font, style and size for the text. Choose 
a color for the text. Press OK. 

Editing Graphic Rollover buttons 
Editing a graphic rollover enables changing the text, font, text color, or any of the graphics in the 
button. This is useful when creating a suite of buttons for a site. From the original button, copy 
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and paste the number of buttons necessary and then edit the buttons to change the text and or 
graphics to what is needed for the site. 

To change the text or graphics in a graphic rollover button: 

Double click on the graphic rollover button.  

The Graphic Rollover Studio dialog comes up. 

Edit the text, font, size or text color. Choose a different over and/or down graphics. Choose Press 
OK. 

Taking rollover buttons apart 
This enables the replacement of the pieces in a rollover button. Each graphic in the button is 
placed on the page. Modify any of the graphics or add new graphics and then use the Rollover 
Maker to recreate the rollover with the new graphics. 

To take a rollover button apart: 

Select the rollover to be taken apart. 

Choose Object>Take Object Apart. 

The three graphics that make up the rollover are placed on the page. 

Adding links to buttons 
A button isn’t a button without a link. The link tells the button what web page to go to when it is 
pressed. 

To add a link to a button from the Links gallery: 

Choose the Links gallery 

Find the link to be added to the button. 

Drag it from the Links gallery onto the button and release the mouse button. 

The link is applied to the button.  

To add a link to a button from the Add/Edit Link dialog. 

Right click on the button.  

Choose Add/Edit Link from the resulting menu. The Add/Edit Link dialog comes up. 

Enter the Name, URL, Description for the link and press OK. 

The link is applied to the button.  

To add a link to a button from the Object Properties dialog: 

Right click on the button.  

Choose Properties from the resulting menu. 
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Click on the Link tab in the dialog. 

Click the Add/Edit Link button. The Add/Edit Link dialog comes up. 

Enter the Name, URL, Description for the link and press OK. 

The link is applied to the button.  

 

 


