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Chapter 10: Text 

Chapter 10: Text 

Web Studio allows you to enter, edit, and design text within the program without the need of a 

word processor. The user interface tools are very similar to a word processor program, so you will 

not need to relearn the features. Besides the standard formatting features such as bold and italic, 

Web Studio contains commands that add animation and design elements to text. See the 

Animations and Text FX chapter for instructions.   

All text is placed on the page in a text object. These 

rectangle objects make page layout very easy because 

you can drag and drop them to any spot on the page, 

align them, and edit the text within them. 

The Text Gallery and the Fonts command in the Text 

tab contain the fonts that you can use to create text for 

your web pages. Web Studio does not download a set 

of fonts with the program. The fonts that you see in 

the Text Gallery and in the Fonts command are actually the ones that you already have on your 

computer.  

Using the Text Gallery and Font Command 

Both the Text Gallery and Fonts command give you a list of the fonts on your computer, so both 

give you identical choices. 

The Font command 

The Font command in the Text tab provides you with a list of available fonts similar to the list 

that you see in word processing programs. You can use this list to choose fonts for a new text 

object and when you want to change the font within a text object.  

 

Web Studio uses the fonts 

you have installed on your 

computer. It does not add 

any other fonts to your 

system.  



The Text Gallery 

In addition to containing fonts, the Text Gallery can be used for four different but related 

purposes: 

Add text objects to a page. Click on the Text Gallery tab to open the gallery. Scroll through 

the fonts in the gallery to find a font that you want to use. Drag and drop the font onto the page 

and a new text object is automatically created. When you begin to type, the font is the one you 

selected from the gallery.  

 

You can also add a new text object using the ribbon command.  

Go to Text > Insert > New Text Object. 

Visually Choose Fonts. The Text Gallery 

displays you a larger example of the font than is 

shown in the Font command.  

Change Fonts. Drag and drop a new font 

from the Text Gallery onto an existing text 

object and the text in the object changes to the 

new font. This is the quickest way to see how a 

font looks on your page. You can change the 

text in several objects at once by selecting more 

than one text object or change only some of the 

text by selecting it before you drag and drop a 

font. 

Choose Web Safe Fonts. The fonts in the 

gallery are color coded so that you can see 

which fonts are considered safe or unsafe. See 

Choosing Fonts and Web Safe Fonts below for 

an explanation.  

Choosing Fonts 

Fonts on web pages have been a problem since the beginning of internet. When you choose a font, 

the font’s name is embedded in the web page; not the actual font. When a visitor goes to your 

website, his browser reads the font name and then looks on his computer to see if the font is there. 

If the browser cannot find the font, it substitutes another. To make this worse, the browser often 

reformats the text and causes a shift in the page layout. This means that if you choose an unusual 

font, it may look totally different on a visitor’s page.  
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Web Safe Fonts 

Web Studio uses color to indicate which fonts your viewers will always have (safe); should have, 

might have, and probably do not have (unsafe). For instance, Arial and Times New Roman are 

always safe. The fonts are color coded to help you distinguish safe and unsafe fonts.  

The Text Gallery uses color to separate the safe and unsafe fonts. 

Black.  These fonts are always safe. 

Blue.  These fonts are probably safe. Visitors with Windows will always have them, but some 

Mac and Unix machines may not. 

Yellow.  These fonts may be unsafe because some viewers may not have them. 

Red.  These are unsafe fonts because they are uncommon and are almost always substituted by 

a browser.  

Safe Fonts 

Black: always safe Arial 

Courier  

Times 

Blue: probably safe Arial Bold 

Impact 

Veranda 

Turn unsafe fonts into graphics 

The best way to use an unsafe font so that it looks good on the internet is to turn it into a 

graphic. This eliminates the confusion with the browsers because there is no font to read.  Text 

always becomes a graphic when you apply special effects to it or merge it with another object. 

However, there are times when you want to use an unsafe font with stand-alone text. In those 

cases, the best way to change the text into a graphic is to allow Web Studio to do it 

automatically.  

You can turn on this function in the Web Site Properties dialog in the Miscellaneous section. 

When this function is checked, Web Studio will automatically turn any unsafe font into a 

graphic when it is uploaded.   

 Click on Caption Bar>Website Properties or right-click over a text object and choose 

Properties from the Text Object Selection Menu. This opens the Web Site Properties dialog. 

 Click on the Miscellaneous section. 

 Click to check the box: Convert objects with Non-Web-Safe fonts into a graphic.  

 Click OK. Web Studio will now automatically convert non-web safe fonts into a graphic. 

 



Working with Text Objects 

Text is placed on a page in a rectangle text object. Each text object can hold as little or as much 

text as you want. The text within the object can be edited and formatted as long as it is in the 

object and has not been turned into a graphic object. Once text becomes a graphic, it can no longer 

be edited. The text object itself can be copied, resized, aligned, and moved just like other objects. 

See the Working with Objects chapter. 

Resize a text object 

Text objects automatically get longer as you insert text. The more text you put in a text object, 

the longer the object becomes. You cannot make the text object any longer than the text within 

it. However, the width of text objects can be changed.  

 Click on the text object to display the selection handles. You do not need to double-click. 

  Drag a side handle to make the object as wide or narrow as you want.  

Adding a Text Object to a Page 

There are several ways to add text objects to a page. You can add a new text object to a page or 

automatically create a text object when you insert text from another source.  

Add a new text object using the New Text Object command  

 Click the Text > Insert > Insert Text> New Text Object command. 

 A new text object is placed on the page with a blinking cursor. 

 Begin to type and the text is placed in the text object at the point of the cursor. 

 

Add a new text object using the Text Gallery 

 Click on the Gallery tab to open the Text Gallery. 

 Scroll through the gallery to view the fonts. 

 Click on the font then drag and drop it onto the page. 

 A new text object is placed on the page with a blinking cursor. 

 Begin to type and the text is placed in the text object at the point of the cursor. 
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Add a new text object using alt + click  

 Hold down the alt key and then click on any blank spot on the page. 

 A new text object is placed on the page with a blinking cursor. 

Automatically Creating a Text Object by Inserting Text 

Web Studio automatically adds a new text object to the page when you add text from another text 

object program or file.  

Insert text from a file 

 Click the Text > Insert > Insert Text> Text from File command. The Open dialog opens. 

 Navigate to the file that you want, choose it, and then click Open. 

 The file is placed on the page in a text object. 

Copy and Paste text to add a text object 

 Select the text. 

Copy.  Click the Copy command. You can also copy text from another program.   

Paste.  Click the Paste/Paste in Place command. 

 

You can also use the right-click menu or keyboard command to copy and 

paste from another text object, another program or a web browser. 

Drag and drop a text file to add a text object 

 Locate the file that you want in any Windows folder.  

 Drag and drop the file directly onto the Web Studio page.  

 A new text object is created with the text that was in the file.  

 

If a file type is not supported by Web Studio, a link to the file is placed on the 

page. Visitors can click on the link to view the file or save it. 

Drag and drop text from another program to add a text object 

 Select the text that you want from the other program. 

 Drag and drop the text onto the Web Studio page. 

 A new text object is created with the text from the other program.  



If you want to: 

Change the text: Double-click to 

activate the text object for editing. 

Move, align or resize the text 
object itself: Click once to select it 

just like other objects. 

Limitations Importing Text 

Word processing programs such as Microsoft Word contain a very rich set of features. Many of 

the features, such as paragraph spacing, cannot be translated into the HTML that is used for web 

pages. This means that if you insert text that was created in Word, it may not look the same. If you 

have a choice, we recommend that you create text in Web Studio to eliminate the need for 

reformatting.  

Selecting Text and Activating Text Objects for Editing 

When a new text object is added to the page, it is ready for you to enter text right away. Later, you 

can edit and format the text within the object. In order to edit, format, or select text within a text 

object, you must double-click on the text object to activate it for editing (editing mode).    

Some functions, such aligning and resizing 

a text object, require that you select the 

object itself, not the text within it. To select 

a text object, you simply click on it.  

 

 

 

 

Activate a text object for editing 

 Double-click on a text object. This gives you editing handles and a blinking cursor. 

 Edit the text within the object. 

 Click a blank spot on the background to deselect the object. 

 



7 

Chapter 10: Text 

Change the background color of text objects when you are editing 

When you double-click to put a text object in editing mode, the background fills with white. If 

you are using white or light colored text, you may not be able to see the text. You can still edit 

the text, but it is more difficult to see. When that happens, you can change the text object’s 

background color that is used during editing. You can use a different editing color for each text 

object. 

 

 

When you change the text editing color of a text object, the color is applied to 

the current text object and any new text objects added to the page. It does not 

change the editing color of any text objects already on the page. 

Choose a background editing color for all text objects 

You can use the Web Studio Preferences dialog to choose an editing color for all of the text 

objects on your site. This option can save you a lot of time later if you want to use light colors 

for your text. This command changes all future text objects. It does not change the background 

editing color of text objects already on the page. 

 Click on Web Studio Button > Options. 

 Click on the Editing Color button in the Text Preferences section. This opens the Colors 

dialog.  

 Click OK when you are finished. Click Cancel to keep the current text editing color. 

 



Change the background editing color in a text object 

 Right-click over a text object. 

 Choose Properties from the resulting Text Object Selection Menu. 

 In the Text section, click on Select Editing Color. 

 Choose the editing color for the text object. 

 Click OK when you are done. Click Cancel to keep the current text editing color. 

 Now double-click the text object to activate it for editing. The background color is the one 

that you chose. 

Select text 

In order to format or edit text, you must select the text within the text object. When text is 

selected, the text becomes highlighted. First double-click on a text object to activate it for 

editing and then you can select the text in several different ways: 

Select any text Click and drag the mouse over the text to select it. 

Select a word Double-click the word. 

Select a paragraph Triple-click within the paragraph. 

Select several words Click on the first word, hold down the shift key and then click on the last 
word.  

Select all text objects Click the Select All command or press ctrl+a. 

Extend a text selection 

After you select some text in a text object, you can add more text to the selection without 

starting again.  

 Press and hold the shift key. 

 Move the mouse to the last word that you want to add to the selection and click over the word. 

All of the words from the selection to the point where you click the mouse are selected.  

Adding and Editing Text 

Before you can add or edit text, double-click on the text object to activate it for editing. 

Add text to an existing text object 

 Double-click the text object to activate it for editing. 

 Click where you want to enter text. You will see the blinking insertion point. 

 Paste or enter text into the object. Text is added to the object at the insertion point. 
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Copy, cut, or delete text 

 Double-click to activate the text object for editing and then select the text. 

 Click on Text > Clipboard > desired command or right-click over the selected text and 

choose the command from the Text Menu. 

Paste text 

After you copy or cut text, you can paste it within the same object, paste it into a different object 

or paste it to replace existing text. 

Paste in the same text object Click in the new location. Click the Paste command, choose 
the command from the right-click menu or press ctrl+v. 

Paste in a different text object Double-click to activate the new text object for editing. Click on 
the location for the text and then paste the text.  

Paste to replace text  If you want to replace existing text with the text on the 
clipboard, select the existing text first, then paste. 

Insert special symbols or characters 

The Insert Special group in the Text tab has a Symbols command that allows you to insert 

symbols in text objects. 

 Double-click to activate a text object for editing. 

 Place the cursor at the insertion point for the character. 

 Click on Text > Insert Special > Symbols. This opens the Character Map dialog. 

 Choose the symbol or character. 

 Click Select. Close the dialog and the symbol is placed in the text object. 

Formatting Text 

You can format text (font, text size, text style) by using the commands in the Text tab. You can 

also change fonts by using the Text Gallery. Most commands require that you activate the text 

object for editing. Some only require that you select the object.  

Change the font in the whole text object 

Use the Font command 

 Click to select the object. 

 Click on Text > Font > Font. Choose a font from the drop down list.  

 All the text in the object is now changed. 



Use the Text Gallery 

 Click on the Text Gallery tab to open the gallery. 

 Scroll to find the font that you want to use. 

 Drag and drop the font onto the text object. 

 All the text in the object is now changed. 

Change the font in multiple text objects 

Use the Font command 

 Hold the shift key and click on all the objects you want to change. 

 Click on Text > Font > Font. Choose a font from the drop down list.  

 The text in all of the objects is now changed. 

Use the Text Gallery 

 Click on the Text Gallery tab to open the gallery. 

 Scroll to find the font that you want to use. 

 Hold the shift key and click on all the objects that you want to change. 

 Drag and drop the font from the gallery onto any one of the text objects. 

 The text in all of the objects is now changed. 

Change the font in selected text within a text object 

Use the Font command 

 Double-click to activate the text object for editing. 

 Select the text that you want to change.  

 Click on Text > Font > Font. Choose a font from the drop down list.  

 The selected text is now changed. 

Use the Text Gallery 

 Double-click to activate the text object for editing. 

 Select the text that you want to change. 

 Click on the Text Gallery tab to open the gallery. 

 Scroll to find the font that you want to use. 

 Drag and drop the font from the gallery onto the selected text. 

 The selected text is now changed. 

Change the background color of a text object 

The default background of text objects is transparent so that you can see the background 

through the text. However, you can change the background color using the Text Background 

command in the Font group of the Text tab. Because the size of the text object hugs the text, use 

the space bar, return keys, and the Justify commands to position the text in the object. 
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 Select a text object. 

 Click on Text > Font > Text Background command. 

 Choose a color in the Color dialog. 

 Click OK. 

Give the text object a transparent background 

There are three ways to make the background transparent on a text object. First, select the text 

object and then: 

1. Right-click over text object>Text Object Selection Menu>Text Background 

Color>Transparent Text Background. 

2. Click on Text > Font > Text Background Color>Transparent Background. 

3. Click on Text > Font > Transparent Text Background. 

 

Aligning Text Within a Text Object 

You can change the alignment of text within the boundaries of its text object. Alignment is a 

paragraph-level attribute, so every paragraph can be aligned independently. The actual alignment 

of text can be affected by indents as well. 

Another way of aligning text is to put paragraphs or sections of text in a separate text object. Then, 

align the text objects in the same way you would align other objects on a page. 

 

To align the text objects, use the commands in the Page Layout tab. 

To align the text within the text object, use the commands in the Text tab. 

Justify text 

 Double-click to activate the text object for editing. 

 Select one or more paragraphs of text.  

 Click one of the Left, Center, Right, or Full Justify commands in the Paragraph group. Left is 

the default justification. 



To make a paragraph, press Enter twice. 

If you do not put space between text, 

then paragraph based commands will be 

applied to the whole text object. 

Indent the first line of a paragraph 

 Double-click to activate the text object for editing. 

 Select a paragraph or part of a paragraph. 

 Click the Indent First Line command in the 

Paragraph group. The first line is indented. 

Indent the whole paragraph 

 Double-click to activate the text object for editing. 

 Select a paragraph or part of a paragraph. 

 Click the Increase Indent command in the Paragraph group. The whole paragraph moves to 

the right. 

Remove an indent 

 Double-click to activate the text object for editing. 

 Select the paragraph or paragraphs. 

 Click the Decrease Indent command in the Paragraph group. The whole paragraph moves to 

the left. 

 

Aligning the text within an object is different than aligning the text objects 

themselves. See Working with Objects for aligning text objects on the page. 

Creating Headings 

You can increase or decrease the font size to create headings by using the Increase Heading 

command in the Paragraph group of the Text tab.  

Add a heading to a paragraph 

 Select one or more paragraphs of text. You do not need to select the whole paragraph. If a 

paragraph is part of the selection it is included in the Header. 

 Click on Text > Paragraph > Increase Heading. The Heading Size 1 is applied to the text.  

 Click on the command again and the Heading Size 2 is applied. Each time that you click on 

the command, the Heading size increases through the seven available choices and then back to 

the first size again. Continue to click on the command to roll through all of the available sizes.  
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Finding and Replacing Text 

The Replace command in the Editing group of the Text tab allows you to find words and replace 

them if you want.  

Find text 

 Click to select a text object. 

 Click on Text > Editing > Replace. This opens the Search/Replace dialog. 

 

 In the Search for field, type in the text that you want to locate. 

 Click Find Next to find the text. 

 Click Find Next repeatedly to find every instance of the text. 

 Click Done when you are finished. 

Replace text  

 Click to select a text object 

 Click on Text > Editing > Replace. This opens the Search/Replace dialog. 

 In the Search for field, type in the text that you want to replace. 

 In the Replace with field, type in the text that you want to use for the replacement. 

 Click Find Next to find the text. 

 Choose Replace to replace the text or click Find Next to ignore it and go to the next 

occurrence. Choose Replace All if you want to replace all occurrences automatically.  

 Click Done when you are finished. 

 



Checking the Spelling 

You can check spelling in one or all of the text objects on a page at the same time. Web Studio 

comes with a dictionary that it uses to check the spelling in your web page. If a word is not in the 

dictionary, you can add it with the Add button in the Check Spelling dialog. . 

Check spelling 

 Select one or more text objects.  

 Click on the Text > Editing > Spelling command. This opens the Check Spelling dialog. 

 Click the Start button to start the spelling check. 

Change, correct, or ignore a word 

The dialog displays the first questionable word in the Word Not Found in Dictionary field. You 

can fix each questionable word in different ways. 

Ignore.  Click this button to 

ignore the word for this one 

time during the spell check 

and move on to the next 

misspelled word. 

Ignore All.  Click this 

button to ignore this word 

every time it occurs.  

Change.  Click this button 

to replace the misspelled 

word with the one showing 

in the Replace With field. 

The checker provides you 

with a suggestion for the 

replacement, but you can key 

in one of your own or choose 

one from the Suggested 

Spellings list. The word that 

is in the Replace With field is the one that is used when you click the Change button. 

Change All.  Click this button if you want to make the same change to all of the same 

misspelled words in the selected text objects. 

Add.  Click on this button to add the questionable word to the dictionary so that it does not 

come up in the spell check again.  

 Click OK when the checker notifies you that the check is finished. 

 Click Done to close the dialog window. 
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Fix duplicate words 

In addition to spelling, the checker looks for duplicate words. If there is a duplicate word, the 

dialog displays a new option so that you can remove the extra word. Simply click the Delete 

Word button to remove the duplicate or click the Ignore button to leave it.  

Add a word to the Dictionary 

When the spell checker displays a word in the Word Not Found in Dictionary field, click on the 

Add button to add the word to the dictionary. 

 

The spell checker can only tell if a word is spelled correctly; it does not check 

grammar. For instance, the words there and their are both spelled correctly, 

but may be used inappropriately. 

Working with the HTML in Text Objects 

Web Studio’s text object uses HTML as its internal data type. This enables you to edit the HTML 

to add advanced features and provides full control over the contents of Text Objects. You can 

create a text object from a HTML file. See also the Working with HTML chapter. 

To create a text object from an HTML file 

 Click on Insert > Text > Text From File. 

 Navigate to the desired HTML file. 

 Select the file and click Open. 

 A new text object containing the selected HTML is added to the page. 

Insert and edit your own HTML into a text object 

 Right-click on the text object. 

 Choose Edit HTML Source from the Text Object Selection Menu. 

 The HTML Editor comes up ready for editing. You can resize the editor to make it a more 

convenient size. 

 Edit the HTML. 

 Click OK to close the Editor. 

 

 


