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Website Basics 

 

Chapter 4: Website Basics 

In its most basic form, a website is a group of files stored in folders on a hard drive that is 

connected directly to the internet. These files include all of the items that you see on your site as 

well as the instructions to put them together. The instructions are written in a programming 

language called HTML and are included in files with the .htm or .html file extension. Web Studio 

provides you with the opportunity to use HTML or ignore it completely. 

Linear and non-linear pages 

When you work with word processing programs, the content is organized in a linear fashion as 

you type one page after another. Each page must be in the proper order so that the content 

makes sense to the reader. 

Websites are non linear because you can create the pages in any order. Each page is built 

separately and it does not matter which page is made first. When you are finished building all of 

the pages for your website, you connect the pages with links. These links allow your visitors to 

go to any page on your website (or on the internet) in any order they desire. Web Studio has a 

Links Gallery and several link commands that help you link your pages together.    

Home page 

The Home page is the first page people see when they visit your site. Web Studio automatically 

makes the first page that you create in a Project the Home page. You can make any page in your 

site the Home page, but you can only have one Home page for your website. 

Page names 

Each page on your site needs a name. The name is used for two things: the name of the HTML 

file on the server and the title that is displayed in the title bar of the web browser when your 

visitors go to that page. The page name should reflect the content of the page. New pages added 

to your website Project are labeled Untitled until you rename them.  

Domain name 

This is the name you pick for your website. Each website has its own unique name. You obtain 

a Domain Name from a Domain Name registration website on the internet. You can get one 

from our hosting company iHostStudio, at ihoststudio.com. 



Web servers and hosting companies 

Web servers.  These are computers that store (host) the sites on the internet. Your website is 

stored securely so that visitors can view your website without connecting to your home 

computer. 

Hosting companies.  These are the companies that own the web servers. You rent space 

from the hosting company for your website.  Some hosting companies offer free space, but it is 

usually quite limited and they add many advertisements to your site. 

 

Although you can use any hosting company for your website, we recommend 

iHostStudio because it is designed to work hand in hand with Web Studio. 

See the Uploading Your Website to the Internet chapter for more information. 

ISP.  Internet Service Providers are the companies that you use to connect to the internet. Your 

ISP could be a dial-up service, cable company, DSL or satellite service. Many include a free 

hosting service for their customers. 

Steps to Getting Your Site on the Web 

This is an overview of the steps that you take to create a website and save it to the internet.   

1. Open Web Studio and start a New Project. 

2. Create the web pages. 

3. Link the pages together. 

4. Preview your site with the Preview Website command. 

5. Obtain a Domain Name and a Hosting Company. 

6. Upload your website to the internet with the Upload Website command.  

Update or change your website 

After your website is on the internet, you can make changes to your Project file and upload the 

changed pages to the internet. The newly uploaded pages replace the current pages on your site.    

Insert the change date on your website 

You can show visitors when you last updated your site. This is a great way to show that you are 

actively keeping up your website. 

 Click on Insert > Text > Last Changed Date. A statement is placed on the page in a text 

object: This page last modified on (date). 

 Drag to position the text object on the page. See the Text chapter for more information about 

text objects. 
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Managing Web Studio Projects and Files  

Web Studio reads its own native Project files (.ows file extension). The Project file contains all of 

the pieces of your website and from there converts the information to HTML. Advanced users can 

import HTML into the HTML Object as well as other objects and pages. This means that Web 

Studio saves your website in two ways: an .ows Project file that can be used within the program 

and a website with the HTML language that is understood by browsers.   

Project file. Web Studio saves its own 

record of your website called a Web Studio 

Project. The Project files have a file extension 

of .ows and can only be read within the Web 

Studio program.  This Project file contains all 

of the information about your Website, much 

the same way a blue print to your house 

contains all of the information about how 

your home is put together. When you add a 

graphic, text, or other objects to the pages of 

your site in Web Studio, they are saved in the Project file. Because a copy of the file is inserted 

into Web Studio, you can modify graphics without changing the original graphic.  

Website. When you are ready to create a web ready website, Web Studio takes all the 

information from the Project file, generates HTML, (the standard language that Web browsers 

understand) and then sends this ready-made website to the location of your choice be it your hard 

drive, a network drive, or the internet. 

Saving and Naming a Project 

It is important to save your Project often while you are working. The Save As dialog appears the 

first time that you save so that you can name your Project. It is best to create a folder called 

Websites in the My Documents folder so that all your website Projects are easy to locate. You 

should also have a folder on a separate drive where you can save a backup copy of your website. 

You may choose to have the backup saved automatically every time you save your project. We 

cannot stress enough the importance of saving a backup copy.  

 

 

Saving Hints 

 Keep your Projects in a separate folder so that you can find them.  

 Always save a backup copy of your website. 

 Saving and backup may take a while with large projects. Be patient—a 

good backup is worth it! 

 

What do you need for a website? 

 Web Studio software 

 Domain name 

 Hosting company 

 ISP (Internet Service Provider) 

 



The Web Studio file 

extension is .ows. 

Save your Project (.ows file) 

 Click on Web Studio Button>Save Project. The Save As dialog opens. 

 Navigate to the folder where you want to save your 

Project. 

 If this is the first time that you are saving the Project, give 

the Project a name.   

 Click Save.  

 The Project is automatically saved with an .ows extension. 

 When you subsequently save your Project, use the Save command in the Web Studio Button. 

This command automatically saves the Project in the same location that you originally saved 

it.  

 The path to your website Project is now something like: 

C:\MyDocuments\WebSites\DogGrooming.ows. 

Save your website to a disk 

You can save your Website to a network or external drive. 

 Click on Web Studio Button>Publish>Save Website Files to Disk. This opens the Browse for 

Folder dialog. 

 Navigate to the drive and folder where you want to save your website’s files. 

 Click OK. 

Make a backup copy of your Project 

It is important to save a backup copy of your Project. This ensures that you do not lose your 

Project in case of a computer crash.  You can manually save or automatically save a Project.  

Manually save a backup 

 Click on Web Studio Button>Save Project As>Backup of the Project. This opens the Browse 

for Folder window. 

 Scroll to the folder in the drive where you want to save the Project. 

 Click OK when you are finished. 

Manually save a backup at the same time you save the Project 

 Click on Web Studio Button > Save Project > Save Project and a Backup. This opens the 

Browse for Folder window. 

 Scroll to the folder in the drive where you want to save the Project. 

 Click OK when you are finished. 

 Web Studio automatically saves the Project to its original location. 
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Automatically save a backup copy of your Project 

You can have Web Studio automatically save a backup of your Project through the Web Site 

Properties dialog. Every time that you save the Project, the backup is automatically saved. If 

you are saving to an external drive, make sure the drive is attached while you save your 

Project. 

 Click on Website Properties at the far right of the Caption Bar. This opens the Web Site 

Properties dialog.  

 

 Click on the General section. 

 Check the box in front of Backup my 

Project File when Saving (Save Project 

from the File menu). 

 Click on the Choose a Folder button. 

This opens the Browse for Folder 

window. 

 Select the folder where you want to save 

your backup. 

 Click OK. 

 A backup is now automatically saved every time you save your Project.  

Remember… 

If you automatically save to an 

external device, make sure the device 

is in place while you work on your 

website. 

 



Centering Your Website in the Browser 

When you create your site in Web Studio, it is aligned to the left of the page. When it is on the 

internet, Web Studio centers it in the browser. If you want your site to be left justified in the 

browser, you can turn off centering. However, depending on the size of your website and the size 

of the visitor’s browser, a left justified website can look unbalanced because it can have a large 

blank area of background on the right side.  

 Choose Website Properties at the far right of the Caption Bar. 

 Click the General section. 

 Click the Center pages of this site in browser checkbox.  

 Click OK. 

 Click Home > Preview > Preview Website to view your pages centered in the Preview 

window’s browser. 

 

Web Site Properties Dialog 

The Web Site Properties Dialog is where you can make global adjustments to your site. Each 

website you construct has properties associated with it. These properties affect the way your 

website is constructed, loaded, and viewed on the internet. You can edit these properties at any 

time by clicking on the Website Properties button at the far right of the Caption Bar. 

 



7 

Website Basics 

 

 

 

 

General section 

 

Your Website Address for use with Google Site Map.  Enter your website address in 

this field to include your website in the Google Site Map.  

Center in Browser.  This causes your pages to be centered in your viewer’s browser when 

they visit your website. 

Project File Backup and Location.  Check Backup my Project file when Saving to backup 

your Project automatically. Choose a folder where you want to backup your Project. 



Home Page section 

 

Home Page’s Name.  This is the name of the file that is used by the hosting company. Most 

companies use “index” but some us “default.” Check with your hosting company. 

File Type section 

 

Page’s File Type.  HTML is the normal file type on the web. Only change this if you are 

making a page with another file type.  
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Uploading section 

 

This section is for customers who are using hosting companies other than iHostStudio. New 

Web Studio 5.0 customers should use Web Studio 5.0 Uploading. Customers who upgraded 

from 4.0 may continue to use the familiar Web Studio 4.0 Uploading wizard or the new Web 

Studio 5.0 Uploading. See the Uploading to the Internet chapter for more information. 

Uploading Options.  If you are using a different hosting company than iHostStudio, check 

Web Studio 5.0 Uploading or Web Studio 4.0 Uploading. 



Attached Files section 

 

Web Studio can automatically upload any additional files when it uploads your website. This 

comes in handy when you are using other programs with Web Studio. These programs typically 

require you to upload some number of JavaScript files and other files in order for the program to 

work. The files are uploaded when you upload your site or a page. They are uploaded in the 

same location (or folder) as the HTML files in your site.  

Use the three buttons in this section to add files, delete files and verify that previously added 

files are still available in the same location on your computer. 

Add Files to List.  Choose files that you want to add from the Open dialog. 

Delete Files From List.  Select a file in the list and then click this button to remove a file. 

Verify Files in List.  Click this button to have Web Studio check to see if the files are still 

available in the same location on your computer. 

Attach files to your website 

 Click on Website Properties at the far right of the Caption Bar. This opens the Web Site 

Properties dialog. 

 Click on the Attached Files button. This opens the Open dialog. 

 Choose the files that you want to add to your website. You can choose more than one file at a 

time by holding down the ctrl key. 

 Click Open after you select all of the files. 
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Miscellaneous section 

 

For transparent and index-colored graphics.  Select the type of graphic file. 

When creating your web site’s pages.  When you create an HTML e-mail, this option 

automatically switches to HTML Tables. 

When creating Text Objects for your web site.  Check this box if you want objects with 

unsafe fonts converted into graphics automatically.  

Web Studio Preferences 

The Web Studio Preferences dialog has a Global Preferences section with options that can be 

turned on and off to save memory. The Text and Links Preferences in the dialog are covered in the 

Text and Links chapters. 

 



Open the Web Studio Preferences dialog 

 Click on Web Studio Button>Options (at the bottom of the list). This opens the Web Studio 

Preferences dialog. 

 Click the box to check (on) or uncheck (off) the following Global Preferences: 

Draw Offscreen.  If you have problems related to memory and/or Windows resources, turn 

this off. It frees memory and resources for you. It results in some flickering of the screen 

when you are redrawing objects and when drawing objects are stacked on top of each other.  

Open previously opened pages.  Turn this off if you have problems related to memory 

and/or Windows resources. When a Web Studio Project is opened, the pages that were 

previously open are reopened. With this turned off, only the pages that were open during your 

last session are opened again. Having just a few pages open at any time uses less memory and 

Windows resources. 

Resample Graphics.  When graphics are resized, they lose some of their visual quality. 

Resampling the graphic increases the visual quality close to the original. 

Previewing Your Website Project 

You can see what your website will look like on the 

internet at any time through the Preview commands. These 

commands allow you to view a single page or your entire 

website. Many items, such as animations, cannot show 

their actions until you Preview your page. The Preview 

Page command allows you to see a single page in the 

browser. The Preview Website or Preview Links commands 

are used to check links and view multiple pages in the 

browser. Previews can be viewed in the Web Studio 

browser or in your Default browser. 

 

 

Since the Preview window is a full featured web browser, you can text all of 

the links and functions in your website. You can even use the navigation tools 

to visit other websites on the internet.  

The Web Studio browser  

This is a fully functioning browser that opens within the workspace.  When you are Previewing 

a page or website, the browser opens in a new page with a highlighted Preview Page/Website 

tab at the top of the page. This browser can also be opened by using the Browse command in the 

View tab. See the Working with Pages chapter for more information about using this browser in 

the workspace. 

The Preview Page command 

allows you to see a single 

page in the browser.  The 

Preview Links or Website 

commands allow you to view 

multiple pages and check all 

of your links. 
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The Default browser  

This setting causes the Preview commands to open your page or website in the internet browser 

that you use on your computer. When you click on a Preview command, your browser 

automatically opens so that you can see your website exactly as it will be seen by your visitors.   

 

The Web Studio browser is the initial setting when the program is installed. If 

you change it to the Default browser, it remembers that setting. 

Set the Preview browser that you want to use 

There are two types of Preview commands: Preview Page (view one page) and Preview Links or 

Website (view the entire website with links). These are described later in this section. All 

Preview commands give you an option to choose the browser that you want to use. 

 Click on the arrow below any Preview command.  

 Click to select the browser that you want to use. This opens the Preview page. 

 



Web toolbar 

In the Default browser, you will use your browser’s navigation tools. When you use the Web 

Studio browser, the navigation tools are displayed above the Caption Bar. Since you are 

connected to the internet, you can even visit other websites by using the Address field.  

 

Back.  Go back to the previously viewed web page. 

Forward.  Advance to the next viewed web page. 

Stop.  Stop the current web page from loading into the browser. 

Refresh.  Reload the current page into the browser. 

Address. Enter the URL to visit another website. 

History. Web Studio keeps track of the sites that you visit during a session. Click on the 

arrow to see the history and choose a URL from the history to go to that site. 

Preview page 

The Preview Page command allows you to see one page in the browser. It is useful when you 

have a large website and want to quickly see the changes that you made on one page. When you 

Preview a page, the links do not work because only one page is in the browser. When you want 

to check links or view your entire website, you must use the Preview Links or Preview Site 

commands. See the instructions in the next section.  

 Click on Home > Preview > Preview Page or Page > Preview > Preview Page. 

 The page is displayed in the browser. Use the browser to review design, check slide shows, 

animations, etc. 

 Close Preview and return to the Web Studio workspace in one of two ways: 

Close the Web Studio browser: Click the “X” on the Preview Page tab. 

Close the Default browser: Close the browser as you normally would. 
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Preview website or links 

The Preview Links and Preview Website commands allow you to Preview your entire site. 

Everything in your site is fully functional during these Previews. This includes Flash 

animations, rollover buttons, links, and everything else. In addition, links to other websites on 

the web takes you to those sites. 

 Click on Home > Preview > Preview Website or Links or Page > Preview > Preview Website 

or Links. 

 The entire website is loaded into the selected browser. 

 Check the links and functions of your website.  

 Close Preview and return to the Web Studio workspace in one of two ways: 

Close the Web Studio browser: Click the “X” on the Preview Site tab. 

Close the Default browser: Close the browser as you normally would. 

 

You can also right-click over a blank spot on the page and choose Preview 

Page from the menu. A blank spot on the page is any place on the 

background that does not have an object covering it. 

Printing and Print Preview 

Printing from Web Studio allows you to print using the full resolution of your printer and includes 

a full featured Print Preview. Many people use Web Studio as a graphics creation program to 

create graphics for use with other programs or to print. Printing graphics from Web Studio yields 

excellent results. For the highest quality printing, turn off Resample Graphics in the Options 

dialog in the WS Button. Turn it back on when you are finished printing. 

 Click on Web Studio Button>Print. This opens the Print Preview window. 

 Move the mouse over each icon to see the function. 

 Click on the icons to zoom in/out, view the page in different orientations, and turn headers 

and footers on or off. 

 Click the Page Setup icon to open the Page Setup window. 

 Choose the printer settings and then click OK. 

 Click the Print button to print the page. 

. 

 

 

 

 

 

 

 


