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Chapter 7: Working with Pages

Your website is built from individual pages. Each page is a file that contains graphics, text, and
other objects that can be viewed in a browser. You can design web pages in any order, choose
which pages to link together, and then upload the linked pages to the internet. These linked pages
make up your website. When you are building your website, you use the pages on the workspace
and the Page List window on the right of the workspace to manage your pages. See The Page List
chapter for a complete description of the Page List.

The pages in your Project are located in the center of the workspace. Each page is displayed in its
own window for easy editing. A colored tab at the top of each page is labeled with the page name.
When you want to work on a page, you bring the page to the front of the other open pages by
clicking on the tab. Pages in the Project are labeled Untitled until you give them a name.

Page margins and page guides. Pages contain page margins and page guides that give you
visual guidelines to help you design your pages and keep them all the same size. The guides are
set according to the size that you want your pages to be when they are on the internet.
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Page Guides

Page size is measured in pixels. The size of a web page depends on the position of the objects on
that page. The page automatically expands to include all of the objects on the page. When the page
does not fit within the browser, the visitor uses scroll bars to see everything on the page. Most
visitors are comfortable scrolling down a page, but it is considered poor design to make your
visitors scroll horizontally. Even scrolling down can be

annoying if the page is too long.

The background always fills

the browser no matter how

large or small you make your
pages.

Page guides help you keep your pages to a
predetermined size. Most designers use 1024 pixels as
the maximum width of the page. The page guides do
not stop you from placing objects anywhere on the
page; they just show you where the edges of the page
size are located. The page guides are not seen on the
internet.

In addition to page sizes for websites, the Page Size command contains sizes for the Apple |
Phone and paper sizes for 8.5x11 Portrait, 8.5x11 Landscape, A 4 Portrait and A 4 Landscape.
These sizes help you use Web Studio to make flyers, signs, and other documents. See the Desktop
Studio chapter.

Set the Page Guides

¢ Go to the Page Layout > Site Setup group.
¢ Click on the drop down arrow next to Page Size

command. Most common page size:
e Set the Page Size in one of two ways 1024 x768

1. Click on the desired size (1024 x 768 is the most
common). This automatically sets the size that you choose.

2.Click on Custom Height and Width. Enter your custom Height and Width and then click OK
when you are finished to close the window and set the size.

The values entered affect how your site is centered in a browser. Experiment
with different values to see the effects. You can enable or disable centering
your website in Website Properties>General section by checking or
unchecking Center pages of this site in browser.
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Page Margins

The page margins are different than the page guides. The page guides set the size of the page and
the page margins put a space between the page guides and the edge of the page. These margins
help you keep objects away from the edge of the page, but they are purely a visual guide and the
sizes do not affect the code that Web Studio creates. The page margins are set at 15 pixels from
the edge, but you can change the size.

Set the size of the Page Margins

Go to the Page Layout > Site Setup group.

Click on Margins. This opens the Margin Sizes dialog.

Key in the Horizontal and Vertical Margin Sizes. The size must be between 0 and 144.
Click OK when you are finished.

Show/Hide the Page Guides and Margins

¢ Go to the Page Layout > Site Setup group.
e Click Show Guides to hide the Page Guides and Page Margins.
¢ Click Show Guides again to show the Page Guides and Page Margins.

Splitting the Workspace to See More than One Page at a Time

In the default view, each page of your website is displayed in the full screen on the workspace.
The pages are stacked on top of each other and you can easily view a specific page by clicking the
page’s tab or clicking the page’s name in the Page List.

However, the workspace can be split so that you can see more than one page at a time. The pages
can be arranged side by side (vertical tab group) or top and bottom (horizontal tab group). This is
helpful when you want to align designs, drag and drop graphics from one page to another, or even
use one of the windows to browse the internet. You can quickly move between full screen and
split screen making this an easy feature to use.



Viewing Pages Side by Side (Vertical Tab Group)

Use drag and drop to view pages side by side

¢ Click on the page tab you want to see in a new window.
o Drag it down until the cursor changes to an icon that looks like a document.
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e Release the mouse button and the page opens in a new window next to the other pages. This
creates a new vertical tab group.

o~ If you drag the cursor down until you see a horizontal gray line, you went too
I far down the page. You will get a horizontal view instead of a vertical view.
See the next section on how to arrange pages horizontally.

o Repeat this to add other pages to the tab group.
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Use the right-click menu to view pages side by side
¢ Right-click over the page tab.
¢ Click on New Vertical Tab Group.
o The page opens in a new window next to the other pages.
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Rearrange the vertical tab groups
¢ Click on a page tab and drag it to the left or the right until it is next to a tab in another group
and then release the mouse.
e That page is now part of the same tab group.

¢ Repeat this to arrange pages in different tab groups or combine all of the pages back to
original full screen view.

kground. Drag to select objects. Right click for menu.
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Viewing Pages Top and Bottom (Horizontal Tab Group)

Use drag and drop to view pages top and bottom

¢ Click on the tab of the page that you want to see in a new window.
¢ Drag the tab all the way down the page until you see a gray horizontal line across the page.
As you drag it, the cursor changes to an icon that looks like a document.

e
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To make a new Horizontal Tab Group
Click on a page tab and drag it
way down toward the bottom of
the page until you see the gray

s line and then release the mouse.

¢ Release the mouse button and the page opens below the other pages.
¢ Repeat this for other pages that you want to open in new windows.
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Use the right-click menu to see pages top and bottom

¢ Right-click over the tab.
¢ Click on New Horizontal Tab Group.
e The page is now below the other pages.

Rearrange horizontal tab groups
o Click on a page tab and drag it to the top or bottom until it is next to a tab in another group
and then release the mouse.
e That page is now part of the same tab group.

¢ Repeat this to arrange pages in different tab groups or combine all of the pages back to
original full screen view.

Scrolling to View All of the Tabs in a Group

When you have multiple pages within a group, some of the page tabs may be hidden because there
is not enough space to see them all. A solid arrow to the side of the page tabs means that there are
some hidden page tabs. Click on the arrow to scroll through the hidden pages. These arrows appear
in both vertical and horizontal split screen views.
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Browsing the Internet in a New Tab Group

The Web Studio browser enables you to browse the internet from within your workspace. When
the browser opens, it displays in a new window with a tab just like your other pages. This means
that you can browse the internet and continue to have full access to your other pages. Now you can
move objects easily from the internet onto your pages. Since there are many free graphic sites on
the web, you can create a graphic for your site and then drag and drop it onto your page. The more
that you use this feature, the more you will like it.

You open the Web Studio browser using the Preview Page command or by clicking on the Browse
the Internet command in the View > Browse Internet group. When the browser is open in the
workspace, the Internet and Browsing tabs are added to the ribbon.



Use the Browse command to browse the internet

¢ Click on View > Browse Internet > Browse the Internet command. This opens a browser
within your workspace in a new page.

e Arrange the page in a new tab group. See the previous section in this chapter about viewing
pages in a vertical or horizontal tab group.

Internet The [ntemet and
m vi Lt . _ Browsing Tabs are
ou lew m rawsing added to the ribbon.

Address

Use the Preview Page command to browse the internet

e Click the tab of the page that you want to Preview.
¢ Click on Home/Page > Preview > Preview Page. This opens the page within the workspace.
The tab is labeled Preview Page: “Page Name.”

Make sure Use Web Studio Browser is selected under the Preview Page
command. If Use Default Browser is selected, then the page’s Preview does
not open within the workspace. It opens with your computer’s browser.

¢ Arrange the Preview Page in a new vertical or
horizontal tab group.

¢ Click on the Browsing tab, enter the URL of a
website in the Address field, and then press
Enter. This opens the website in a new page on ) ]
the workspace. You can use the navigation tools You can also view Web Studio
and Address field to browse the internet from Wiki in the Preview page.
this page.

You can drag and drop graphics
from one page to the other. This
includes graphics from the internet.
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Use the browse tools to navigate the internet

When you use the Web Studio browser, the navigation tools are displayed above the Caption
Bar. Since you are connected to the internet, you can even visit other websites by using the
Address field in the browser.

Web Studio keeps track of the websites that you visit when you browse the internet from the
workspace. The history is kept during one session and is erased when you close Web Studio.

.l
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The Page Properties Dialog

Right-click over a page’s name in the Page List and choose Page Properties from the Page
Background Menu to activate the page’s Object Properties dialog. This dialog provides you with
information about the page including the size and download times. If you use iHostStudio as your
hosting company, you can create a Password protected page in this dialog. It also contains a
Section where you can place Notes about the background.



File Type section

Fiie Type Page's File Type
Size & Down... File Type on e Web
Pasewornd Choose a File Type | [Lhéml Hyperiext -
HTML Build Motz )
MNormal file type on the Web is himil
Notes Use te ofer fl typss only when creafing a paos of hat type. Using
e wrong fle type may cause the page o nol display comecly.
ok | caca | b | 0|

The normal file type on the web is .html. Only use other file types when
you are creating a page of that type. If you use the wrong file type the page may not display
correctly.

Size and Download Times section

fﬂhjac:t Properties
File Type Page's File Size on Web

Size & Down.. This is e approximate space fis page will ke on fe web. 5K
Pazzwiond Page's Download Times
HTML Build These are approximaie Bmes il will iake for viewers of his page o dowmload it

Wil 28 8K Modem: 1 seconds
Wil 33K Modem: 1 s=conds
Wik 56K Modem: 4 zaconds

Wit ISDN: 4 z2conds
With 334K DSL: 1 seconds
Wit T1/Cable/DSL: 1 seconds

| 0K | Cancel

MNoes

This section allows you to check the total memory size of your page and the approximate time it
will take your viewers to download the page to view it. This is helpful when your page contains
a lot of graphics, such as photos, that can slow the download times.
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Password section

Object Properties 3
Fil= Type Password Protect Page for iHostSudo Hosting Caly
Size & Dowm.. Passwiord |Members
Passwond
HTML Build The passwoed eature caly woeks wish hoss pages and webails hat are
Motsz using iHostSudo websiie hosing.
I you aren't using iHostCudio, contact your hosing service 1o se ifhey
ofier passwond profecied pages.
MNode that if hey do, his didog won't work. . eyl have her own method
fo pazzwond profect your pages hat you'll have o uss.
oK | Cancel Appl Hely

If you use iHostStudio as your hosting company, you can create a password protected page on
your site. The password protect does not work in Preview, but you can check it with trial

hosting.

HTML Build Section

Object Properties E

File Type Page HTML Cpéons
+ Build an HTML Page (normal 'WebSudio way 0 build pages)

¢ Buikd Page without HTML Tags {advanced, add HTML io (Before All Tags")

Size & Dow...
Password
HTML Build ... ]

Hotes

0K | Cancel Appl

Notes section
You can use this area to keep notes about the page or the background.



