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Chapter 9: Working with Objects 

Chapter 9: Working with Objects 

Objects are the building blocks for your website’s pages. Every item on your page is an object. 

This includes photos, graphics, banners, text, and other types of objects.   

For many operations, Web Studio does not distinguish between different types of objects; most of 

the rules for working with objects are used for all types of objects. Objects can be resized, 

rearranged, combined, and much more. Each object is on a separate layer. This means that you can 

easily overlap and position them on the page. The Page Layout tab and the object’s right-click 

Selected Object Menu contains commands that can help you size and align objects on the page. 

This chapter explains you how to work with objects in general. Other chapters provide instructions 

for specific types of objects.  

Adding Objects to a Page 

There are several ways to add objects to a page. You can drag and drop objects from the galleries 

onto the page or you can insert your own graphic files.  

Drag an object from a gallery 

 Click on a gallery’s name tab to open the gallery. 

 Scroll to find the object. 

 Drag and drop the object onto the page.  

 Click and drag the object to position it on the page. 

Insert an object using the Insert command 

The Insert tab contains a large selection of objects that can be inserted into a page. 

Backgrounds, text, Flash, videos, and sounds are among the objects that can be inserted. Here 

are general instructions for inserting a picture or graphic. Individual chapters such as the Multi 

Media and Text chapters cover specific command instructions.   

 Click on Insert > Illustrations > Picture command. The Open dialog then opens. 

 Navigate to the object file that you want to insert, such as a GIF file. 

 Select the file. 

 Click Open. The object is placed on the page. 

 Click and drag the object to position it on the page. 

 

 



Copy and Paste graphics or text from other applications 

 Locate the graphic object or text in another application. 

 Copy the object or text from the application. 

 Go back to your Web Studio project and Paste in one of two ways: 

1. Click on Home > Edit > Paste. 

2. Right-click over a blank spot on the page and choose Paste from the Page Background 

Menu. 

 Click and drag the object to position it on the page. 

Drag a file from Windows onto the page 

 Locate the file that you want in any Windows folder. 

 Drag and drop the file directly onto the page.  

 Click and drag the object to position it on the page. 

Drag and drop a graphic or text from a browser  

 Open the browser and locate the graphic that you want to use.  

 Select the graphic or text. 

 Drag and drop the graphic or text directly onto the page.  

 If you drag text from the application, a new text object containing the dragged text will be 

automatically created and placed on the page. 

Drag and drop a graphic or text from other applications 

 You can do this if the other application supports drag and drop.  

 Locate the graphic or text from the other application.  

 Select the graphic or text. 

 Drag and drop the graphic or text directly onto the page.  

 If you dragged text from the application, a new text object containing the dragged text is 

created automatically and placed on the page. 

 

You can drag and drop any file from Windows onto a page or object. If the 

file is one of the 50 files that are recognized by Web Studio, then Web Studio 

manages the file appropriately. If the file is a graphic for example, it is turned 

into a graphic object on the page. If it is a Word Document file, it is turned 

into a text object. If the file does not translate into a native Web Studio object 

type, Web Studio converts it into a download link. 
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Selecting Objects 

Many functions and commands require that you select one or more objects before you can perform 

the command.  When you select multiple objects, it is sometimes necessary to select them in a 

certain order. Instructions for individual commands tell you whether selection order is important. 

Generally speaking, the selection order is important when you want to view objects together like 

Slide Shows.   

Selection handles 

When you select an object, you see a group of 

black boxes around the object. These are selection 

handles. You can move, align, crop, resize, and 

perform many other functions with an object after 

it is selected. 

Select an object by clicking 

 Move the mouse over the top of an object. 

 Click the left mouse button. 

 The selected object now displays selection handles. 

Deselect an object 

There are two ways to deselect objects: 

1. Click on a blank spot on the page to deselect an 

object. Remember that when a large graphic is a 

backdrop on your page, then you must go to the far 

right or left in order to find a blank spot on the 

page.  

2. Hold down the shift key and double-click over the 

object. 

Select multiple objects by clicking 

If objects are already selected on the page, then deselect them before you begin this selection 

method. If you do not do this, then the new selections will be added to the previous selections. 

See the Add objects to an existing selection later in this section. 

 Press and hold the shift key. 

 Click on a series of objects. 

 

Sometimes, the selection order 

is important. For example, the 

order in which you select 

graphics determines the order 

you will see them in an 

animation.  These instructions 

will tell you when to 

determine a selection order. 

 



Select multiple objects by dragging 

 Move the mouse to a blank spot on the page. 

 Press and hold the left mouse button. 

 Drag the mouse so that a rectangle appears and touches all of the objects that you want to 

select. The rectangle does not need to surround the objects. 

 Release the mouse button. 

 All objects are selected. 

Select all objects 

There are two ways to select all of the objects on the page: 

1. Use the Select All commands: Text > Clipboard > Select All or Home > Edit > Select All. 

2. Press ctrl+a. 

Deselect all objects 

 Click on a blank spot on the page in order to deselect all objects. Remember if a large graphic 

is the backdrop on your page, then you must go to the far right or left of the page to find a 

blank spot.  

Add objects to an existing selection (extend a selection) 

 Press and hold the shift key. 

 Click the other objects that you want to add to the selection. 

Remove objects from an existing selection 

 Press and hold the shift key. 

 Double-click on each object that you want to remove from the selection. 

Moving Objects 

There are several ways to move objects on the page and to move them from one page to another.  

Move one object with the mouse 

 Press and hold the left mouse button over an object. 

 Drag and drop the object to the new location. 
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Move multiple objects with the mouse 

 Select the objects. Remember to hold the shift key while you select more than one object. 

 Press and hold down the left mouse button over one of the objects. 

 Drag and drop the objects to the new location. 

Move objects to a specific position numerically  

 Right-click over the object and choose Properties from the Selected Object Menu. 

 This opens the Object Properties dialog. See the end of this chapter for a complete 

description of all the sections in the Object Properties dialog. 

 In the General section, check the Lock Object Size checkbox.  

 

 Enter the new position in the Left and Top fields. Do not enter a Right or Bottom position. 

These are determined automatically depending on the size of the object and the page. 

 Now, un-check the Lock Object Size checkbox.  

 Click OK to close the Object Properties dialog. 

Nudge objects one pixel at a time 

 Select one or more objects.  

 Use the up, down, left, or right arrow keys on the keyboard to nudge the object one pixel at a 

time. 

 Press and hold one of the arrow keys to move the object continuously. 



Nudge objects ten pixels at a time 

 Select one or more objects.  

 Hold down the shift key. 

 Use the up, down, left, or right arrow keys on the keyboard to nudge the object ten pixels at a 

time. 

 Press and hold one of the arrow keys to continuously move the object. 

Constrain movements to horizontal or vertical 

 Select one or more objects. 

 Press and hold down the shift key. 

 Click on an object and drag it horizontally or vertically. 

  To change directions, release the shift key, press again and drag the object.  

Push objects down the page 

This command adds space below an object which causes all of the objects below it to be pushed 

down the page. This is useful for adding space 

between objects on the page so you can insert 

new objects. 

 Select the object that you want to insert space 

below. 

 Press the P key to push all of the objects below 

the selected object down the page one pixel at 

a time.    

 Press and hold the P key to push the objects down multiple pixels at once.   

 Press and hold the shift key, then press the P key to push the objects down ten pixels at a 

time. 

Pull objects up the page 

This command removes the space below an object so that objects below it are pulled up the 

page. This is useful when you delete an object and you want to move everything up or when 

you want to tighten the space between objects. 

 Select the object that is above the space you want to remove. 

 Press the u key to delete one pixel of space at a time below the selected object and pull the 

objects below it up the page.  

 Press and hold the u key to move the objects up multiple pixels at once. 

 Press and hold the shift key, then press the u key to pull the objects up ten pixels at a time.   

The P key (push down) and the U 

key (pull up) are hot keys for 

moving objects. Hot keys are not 

case sensitive. 
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Paste in Place puts 

objects in the same 

place on the new page 

as they were on the 

previous page. 

Move objects to another page using Copy and Paste. 

 Select one or more objects.  Hold down the shift key if 

you are selecting more than one object. 

 Choose Copy or Cut from the ribbon or the right-click 

Selected Object Menu. 

 Click the page tab to go to another page. 

 Choose Paste or Paste in Place from the ribbon or 

from the right-click Selected Object Menu. 

Move objects to another page using drag and drop 

 Select one or more objects.  Hold down the shift key if you are selecting more than one object. 

 Hold down the ctrl+shift keys. 

 Click on the selected objects and drag them onto the page tab where you want them to go 

(keep holding the ctrl+shift keys and mouse). This opens the page where you want the objects 

to go. 

 Now drag the objects off the tab and drop them onto the page where you want them to go. 

 

This is the easiest way to move objects if you do not need to use Paste in 

Place. 

Split the screen to drag and drop objects from one page to another page 

The Working with Pages chapter presents detailed instructions for working with a split screen. 

This section contains an overview of the steps necessary to create a split screen in order to drag 

and drop objects. 

Split the screen 

 Click on the tab of the page that you want to see in a new window. 

 Drag it down until the cursor changes to an icon that looks like a document. 

 Release the mouse and the page opens in a new window alongside the other windows. 

Drag and drop objects 

 Select one or more objects.  Hold down the shift key if you are selecting more than one object. 

 Hold down the ctrl+shift keys. 

 Click on the selected objects and drag them onto the page where you want them to go. 

Go from split screen back to full screen view 

 Click on the page tab of the new window. 

 Drag and drop it next to the other page tabs. 

 The windows are now in full screen view. 



Editing an Object’s Contents 

All objects contain “stuff”, whether that stuff is text, a photo, a slide show, a video or a Flash 

animation. Most objects or their properties can be edited in Web Studio.   

As a general rule, double-clicking on an object opens a dialog that allows the object to be edited. 

Objects that do not have a specific editor use the Properties dialog to edit properties.   

Double-click. This opens the object’s editor.  

Right-click. This gives you the Selected Object Menu. Choose Properties to display the dialog.   

Aligning Objects 

The Align commands in the Page Layout tab can help you quickly and easily align objects to the 

page and to each other. You can also use the right-click menu to perform these commands. 

Align tops, bottoms, left sides, and right sides 

You can align a group of objects so that they are in perfect alignment with the top, bottom, left 

sides or right sides. Web Studio uses the highest, lowest, left-most, and right-most of the 

selected objects to bring the others into alignment. This is useful when working with buttons, 

photos or any other objects. 

 Select the object that is the highest, lowest, left-most, or right-most. This is the object Web 

Studio uses to align the other objects. 

 Hold the shift key and then click on the other objects in any order to extend the selection. 

 Click on Page Layout > Align > Tops, Bottoms, Left or Right.  

 The objects are now aligned in relation to the first object selected. 

Using the Grid to Align Objects 

Many professional graphic designers use grids for creating page layouts. A grid helps you place 

objects and align them along perfectly straight horizontal and vertical lines.   

The Web Studio grid is set at 36 pixels for both the horizontal and vertical measurements. This 

corresponds to ½ inch in each direction. You can change the grid size and establish strict 

alignment rules when designing your pages.  

 

If you change the location or size of an object numerically with the Object 

Properties dialog, then it will not align itself to the grid. Web Studio assumes 

that you want to “violate” the grid when you do this. Note that cropping does 

not snap to the grid. This is because cropping is based on the visual content of 

the graphic, not its size or location. 
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Turn the grid on and off 

 Click on Page Layout > Grid > Show Grid. This turns on the grid. 

 As you move objects on the page, they   “snap” to align with the closest line in the grid. 

 To turn the grid off, click on Page Layout > Grid > Show Grid again.  

 

Whatever corner of an object is the closest to the grid is the one that is 

snapped to the grid. For instance, if the upper left corner of an object is 

closest to the grid, then the object’s snaps to the upper left corner to the grid. 

Change the grid size 

 Click on Page Layout > Grid > Grid Settings. This opens the Grid Size dialog. 

 Enter a value for the horizontal size and/or the vertical size. 

 Click OK. 

 

 

The grid display changes as the settings get smaller.  

 



Centering Objects 

The Center commands in the Page Layout tab allow you to center objects to the page or to one 

another. You can also use the right-click Selected Object Menus to perform these commands. 

Center objects relative to each other 

This is one of the situations in which the order you select the objects matters. The first selected 

object is the basis for the centering of the other objects. You can center the objects horizontally 

or vertically. 

 Select the first object. This is the object that Web Studio uses to center the other objects. 

 Hold down the shift key and then click on the other objects in any order to extend the 

selection. 

 Click on Page Layout>Center > Horizontal or Vertical. Objects are centered in relation to the 

first selected object.  

 

Center objects relative to the page 

Web Studio uses page size as the measurement for centering objects on the page.  

 Select the objects. 

 Click on Page Layout > Center > To Page. 

 The objects are centered on the page.  

 

To set the page size: Click on Page Layout > Site Setup group. Click on 

the drop down arrow next to the Page Size command and then click on the 

desired size (1024 x 768 is the most common size). 
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Stacking Objects 

Each object on a page sits on a different layer. Layers are like pieces of transparent paper that are 

stacked on top of each other. You can arrange the objects so that you can see all of them through 

the paper, or you can overlap them in different ways.  

As an object is moved, it can overlap other objects 

that are located on lower layers. You can rearrange the 

stacking order to create your design and arrange the 

objects for things like slide shows. 

The Bring To commands in the Page Layout tab allow 

you to bring objects forward or backward through the 

layers. You can also use the right-click Selected Object Menus to perform these commands.  

Move an object to the top or bottom of the stack 

 Select an object. 

 Click on Page Layout > Bring To > Front or Back. 

 The object is moved to the front or back of the stack. 

Move an object up or down through the stack 

When you move an object forward or backward through the stack, you will not notice any 

change unless the items are overlapping.   

 Select an object. 

 Click on Page Layout > Bring To > Forward or Backward.  

 This moves the object Forward or Backward one layer at a time. Repeat to continue to move 

the object through the stack.   

Spacing Objects 

The Space group commands allow you to quickly space a series of objects evenly across or down 

a page. This is especially helpful when you are working with repeating objects, such as buttons. 

You can also space the objects so that their edges touch or so that there is only 1 pixel between 

them. These commands ignore the Snap to Grid function in order to ensure that the spacing is 

perfectly even. You can also use the right-click menus to perform these commands. 

Space objects vertically or horizontally  

 Put the top and bottom objects in the desired position. The other objects are spaced evenly 

between these two. 

 Select all of the objects. 

 Click on Page Layout > Space > Vertically or Horizontally. 

Each object is on a separate 

layer. This means that you can 

easily overlap or stack them. 



Space with 1 pixel between objects 

 Select the objects that you want to space. 

 Press and hold the ctrl+shift keys. 

 Click on Page Layout > Space > Vertically or Horizontally. 

Space objects with edges touching 

 Select the objects that you want to space. 

 Press and hold the ctrl key. 

 Click on Page Layout > Space > Vertically or Horizontally. 

Resizing Objects 

You can resize most types of objects. The easiest way is to select an object and drag the handles to 

make the object smaller or larger. If you use the corner handles, then the object will grow 

proportionally larger or smaller. You can use the other handles to enlarge or reduce the object in 

one direction only. 

 

 

 

Hold down the shift key and then drag a corner handle to resize the object in 

both directions.th directions. 

 

Objects that cannot be resized  

Some objects cannot be resized due to the nature of their content. For instance, you can make 

text objects wider, but not longer than the text within the object. Two other types of objects that 

cannot be resized are: 
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Objects are resized to match the 

size of the first object selected. 

Therefore, the selection order is 

important. 

1. Backgrounds cannot be resized since the content of “size” does not apply to backgrounds.  

2. HTML objects can be resized. However, the content of the HTML object will ultimately 

determine the size when it is Previewed or in a browser. 

Resize by dragging 

 Select an object. 

 Move the mouse over a handle until you see an arrow. Use a corner handle to resize the object 

and keep its proportions. Use a side or top handle to resize the object in one direction. 

 Hold down the left mouse button and drag the handle in order to resize the object. 

Resize an object numerically 

 Right-click over an object and choose Properties from the Selected Object Menu. 

 Check the Resample Graphic box prior to resampling. This helps increases the visual quality 

of the object. Do this if the graphic has not previously been resampled. 

 Resize non-proportionally: fill in the Height and Width fields. 

 Resize proportionally: check the Proportional Resizing box and then fill in a Height or Width. 

Resize to an exact size  

 Right-click over an object and choose Properties from the menu. 

 Resize non-proportionally, fill in a Height and Width. 

 Resize proportionally, check the Proportional Resizing box and then fill in a Height or Width.  

Resizing Objects to Each Other 

Use the Make Equal group commands to make objects equal size, equal width, or equal height. 

The objects are resized to match the size of the first object selected; therefore the selection order is 

important.  

Resize multiple objects to the same size 

 Click on the Page Layout tab.  

 Select the object that is the size that you want the 

other objects to become.   

 Press the shift key and then select the remaining 

objects in any order. 

 Click on the Make Equal > Size, Width or Height commands in order to resize the objects. 



Resampling Graphics after Resizing  

When most graphics are resized, they lose some of their visual quality. Resampling the graphic 

increases the visual quality. However, when you resample a graphic or photo much of the original 

information is lost. This does not matter when the graphic is going to be used on the internet. 

The difference between a graphic that is resampled and one that is not resampled is evident when 

the page is printed. If you print a Web Studio page that contains resampled graphics, then the 

printout will display low-quality graphics even though the text looks high-quality. If you do not 

resample a graphic when you resize it, then the print will be a higher quality.  

Therefore, unless you are using the graphics on your page for printing, choose to resample them.  

Web Studio automatically resamples graphics when you resize them. You can choose to turn off 

this function, but then you will need to remember to resample graphics individually after resizing 

them. 

Turn automatic resampling on and off 

 Click the Web Studio Button>Options. This opens the Web Studio Preferences dialog. 

 

Turn on automatic resampling.  Click to check the box for Resample Graphics when 

resizing. 

Turn off automatic resampling.  Click to uncheck the box for Resample Graphics when 

resizing.  

 Click OK when you are finished. 

Resample a graphic after resizing 

You can resample a graphic in two different ways: 

1. Right-click on the graphic and choose Resample from the Selected Object Menu. 

2. Double-click on the object and check Resample Graphic in the General section of the 

Object Properties dialog. 
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Cropping Objects 

Cropping removes a portion of the graphic by trimming its edges. Cropping is different from 

resizing because it cuts off a portion of the object. When you resize an object, the whole object 

becomes larger or smaller without losing any part of the image. 

Objects that cannot be cropped 

Some objects cannot be cropped due to the nature of their contents.  

 Text objects cannot be cropped. 

 Thumbnails cannot be cropped. However the photo or graphic that is used to create the 

thumbnail can be cropped before it is turned into a thumbnail. 

 Flash animations, audio and video objects, rollover buttons, animations, HTML objects, and 

templates cannot be cropped.  

Crop the top, bottom, and sides 

 Select the object to be cropped.  

 Press and hold the C key—you do not need to press the shift key 

 Drag the top, bottom, or side selection handles to resize in on direction. 

 Drag in order to crop. As you drag you will see a cropping rectangle that shows what portion 

of the graphic will be kept. 

 Release the mouse to crop the graphic. 

 

Crop in two directions at the same time  

 Select the object to be cropped.  

 Press and hold the C key—you do not need to press the shift key. 

 Move the mouse over a corner handle. 

 Drag to crop in any direction. As you drag you will see a cropping rectangle that shows what 

portion of the graphic will be cropped and deleted. 

 Release the mouse to crop the graphic. 



Duplicating Objects 

There are several ways to duplicate objects. The Copy and Paste commands are located both on 

the ribbon and in an object’s right-click menu. The usual keyboard shortcuts can also duplicate 

objects. One of the quickest ways to duplicate an object is to hold the ctrl key, then click and drag 

the duplicated object. Actually, you do not need 

to drag the object to duplicate it. But if you do 

not drag it, you do not see it because the duplicate 

is directly underneath the object. 

If you are copying items that will be pasted on 

another page, you can use Paste in Place to put 

the objects in the same spot on the new page.  

Duplicate using Click and Drag 

 Press and hold down the ctrl key.  

 Click on any object and drag.  

 A new, duplicate copy of the original object is dragged out from under the original.  

Duplicate using Copy and Paste  

 Select the object. 

 Click Home > Edit > Copy. 

 Click Home > Edit > Paste. 

 The duplicate object is pasted onto another spot so that you can see where it is. 

 

You can also use the right-click menu to copy and paste. If you right-click 

and do not see Paste as an option on the menu, then you are right-clicking 

over another object. Go to a blank spot on the page and then right-click. You 

will see the Paste command. 

Duplicate using Copy and Paste in Place 

 Select an object on the open page. 

 Click Home > Edit > Copy. 

 Click on a page tab to open the new page on which you want to place the object. 

 Click Home > Edit > Paste in Place. 

 The duplicate object is pasted in the same location on the new page as its location on the 

previous page.  

 

 

If you click on an object when the 

ctrl key is pressed, you create a 

duplicate. If you do not drag, the 

duplicate hides under the object so 

you cannot see it.  
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Grouping Objects 

The Group commands in the Create tab allow you to merge and group objects. You can also use 

the right-click Multiple Selected Object Menus to perform these commands. 

Group.  You can group objects together so that can work faster. Grouping causes objects to retain 

their positions in relationship to each other. After you group objects you can copy, paste, flip, 

rotate, and perform other functions on the group as a whole. You can group and ungroup any 

objects at any time. 

Merge.  You can merge objects together 

to create new objects. For example, you 

can merge a graphic and a text object 

together to create a photo with a caption. 

Or, you can merge a colored rectangle 

with a photo to create a border. When you 

merge objects, you create an entirely new 

object. Unless you do an immediate 

Undo, merged objects cannot be 

unmerged later. 

When using large fonts, an effect called aliasing can occur when the text is merged with a graphic. 

Aliasing results in colored dots surrounding the outline of the text. This is most prominent when 

light colored text is merged with a dark background. If you see aliasing on your merged graphic, 

then create the graphic in a dedicated graphics program such as Photoshop or PaintShopPro. 

Group and ungroup objects 

 Select all objects in any order. 

 Click on Create > Group. 

 This groups the objects together so that when you drag one of the objects in the group, the 

whole group moves as one object. The objects retain their geometric relationship to each 

other. 

 When you want to ungroup, click to select the group and then click Create > >Un-group. The 

objects are then no longer grouped.  

Merge and unmerge objects 

 Arrange the objects as you want them to appear. If you want to arrange the stacking order, go 

to Page Layout > Bring to > Front, Back Forward, or Backward.  

 Select the objects. 

 Click on Create > >Merge. The objects are then merged.  

 To immediately unmerge, click ctrl+z to Undo. The merged objects cannot be unmerged later. 

 

Tip: When you merge two or more 

objects, they become one new object. This 

means that they cannot be unmerged later. 

Make copies of the objects before they are 

merged and keep them on a blank page in 

case you need them later. Do not include 

that page in the Footer Links.  



Some objects cannot be rotated because 

of their contents. This includes buttons, 

HTML objects, templates, flash, sound 

and video objects. 

Rotating Objects 

Objects can be rotated, flipped, and reversed by using the Special Effects commands in the Photo 

group of the Create tab. You can use these 

commands on a single object or a selection 

of objects. See the chapter on Working with 

Photos for a complete list of the Special 

Effects commands. 

Rotate, flip or reverse one object 

 Select the object. 

 Click on Create > Photos > Special Effects command>Rotate, Flip, or Reverse. 

Rotate, flip, or reverse multiple objects 

 Select multiple objects. 

 Click on Create > Photos > Special Effects>Rotate, Flip, or Reverse. 

 

Text objects are turned into graphic objects when they are rotated. This 

means that the text can no longer be edited. Make sure that your text is 

correct before you rotate it. 

Highlighting Objects 

When you are working with multiple objects, it is almost impossible to remember all of the 

applications that you used and all of the changes you applied to each object. In addition, many 

functions associated with objects, such as links, are invisible. The Highlight Object commands in 

the View tab provide you a quick way to check the status of the objects on your page. When you 

click on a command, Web Studio places a red box around every object that applies to that 

command.   
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Objects With Links.  This option reveals every object on the page that has a link. 

Objects That Overlap.  This is important when you think that you may have “lost” an object. 

One object can be hidden under another. It is also important to use this feature when you use the 

Save Page As HTML E-mail command. You cannot use overlapping objects when creating these 

e-mails.   

Objects With Unsafe Fonts.  Web Studio converts unsafe fonts into a graphic to retain the 

design integrity of your pages. This option reveals all objects with unsafe fonts. See the Text 

chapter for information about safe and unsafe fonts. 

Objects With Added HTML.  This option reveals objects that contain added HTML. 

Objects With Notes.  This option reveals objects that have added Notes in their Object 

Properties dialog. 

Turn the Highlight commands on and off 

 Turn On: Click on View > Highlight Objects > Highlight command.  

 Turn Off: Click on View > Highlight Objects > Don’t Hilite. 

Working with Protected Graphics 

Web Studio has the ability to read more than 20 different types of graphic files and convert them 

into a form that can be used on the web. For practical purposes, the web can only use two different 

file types: GIF and JPEG. When you add a different type of file, Web Studio converts the file into 

one of those file types. 

If you add a GIF or JPEG, Web Studio will 

decompress it and change it into a 24 bit image. 

This change allows you to change the graphic, 

crop it, add shadows, etc. Later when you build 

your site, Web Studio will turn it into a GIF or 

JPEG. 

Some people, however, spend time optimizing 

their graphics for the web and want to use them 

on the web exactly as they created them. They do not want Web Studio to decompress the graphics 

or to create new files. In this case, the GIF or JPEG needs to be “protected” from Web Studio’s 

normal graphics processing. 

When you add a GIF or JPEG as a Protected Graphic, that exact image will be displayed on your 

website. In addition, Web Studio saves these images on the web in such a way that you can use 

them repeatedly on multiple pages and the file is uploaded only once.  

 

 

Web Studio adds the JPEG or GIF 

file type based on what it thinks the 

file should be saved as. However, 

you can change the file type.  



Insert a Protected Graphic 

You can insert any graphic as a Protected Graphic. This is done through the Insert Protected 

command. 

 Click on Insert > Illustrations > Picture command>Protected Graphic from File. This opens 

the Open dialog. 

 Navigate to the graphic file that you want to insert. 

 Select the file. 

 Click Open. The graphic is placed on the page as a Protected Graphic. 

Convert a normal graphic to a Protected Graphic 

If you create a graphic in Web Studio, you can convert it to a Protected Graphic. You may want 

to do this to protect it from changes, or to use it multiple times on different pages without 

uploading multiple times. 

 Right-click over the graphic. 

 Click on the Selected Object Menu>Turn into Protected Graphic. 

 In the Save As dialog, choose a folder in which you will place the graphic. 

 Enter a name and choose a file type.  

 Click Save. 

Save Protected Graphics 

Protected graphics are not stored in the Web Studio Project file. They are saved in a separate 

folder just like other graphics and files that you add to your site. We suggest that you create a 

folder in My Documents and label it Protected Graphics so that you can find protected graphics 

easily. 

Lost Protected Graphics 

If a protected graphic is moved, deleted, or renamed, then Web Studio will not be able to find it 

on your disk. When you Preview or Save your site to the internet, Web Studio will attempt to 

find the file. If it cannot find it, you will see a dialog asking you to locate the file. If you cannot 

locate it, then you can tell the dialog to Ignore the missing file. In this case, the file is not 

uploaded. Each page that used the lost graphic will display a box with a red X in it in place of 

the original graphic.  

Flash files and Protected Graphics 

All Flash files are treated as protected graphics. They may be used many times in a site, but they 

need only to be uploaded once. They are not modified in any way by Web Studio. 
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Allowable operations with Protected Graphics 

Protected Graphics can be moved, merged, and resized. No other graphics manipulations can be 

applied to them. Note that merging a Protected Graphic with another object turns the Protected 

Graphic into a normal graphic object. Web Studio will not allow any illegal operations on a 

Protected Graphic. 

Convert Protected Graphics to normal graphics 

 Click on the Protected Graphic that you want to convert. 

 Press and hold down the G key on the keyboard. 

 Click again on the Protected Graphic that will be converted. 

 A new, normal, graphic is created and placed on the page near the Protected Graphic. 

 You can then delete the Protected Graphic by selecting it and then hitting the delete key. 

Convert a series of Protected Graphics to normal graphics 

 Select the first Protected Graphic that you want 

to convert. 

 Hold down the shift key, click on the remaining 

graphics and then release the shift key. 

 Press and hold down the G key on the 

keyboard. 

 Click on any of the Protected Graphics that will 

be changed. 

 New, normal graphics are placed on the page 

near each of the Protected Graphics. 

 You can delete the Protected Graphics by hitting the delete key. 

Convert all of the Protected Graphics on a page to normal graphics 

 Click on Text > Clipboard > Select All or press ctrl+a on the keyboard. 

 Press and hold down the G key on the keyboard. 

 Click on any of the Protected Graphics that will be converted. 

 New, normal graphics are placed on the page near each of the Protected Graphics. 

 You can delete the Protected Graphics by hitting the delete key. 

 

 

 

 

 

The G key is a hot key that 

converts Protected Graphics to 

normal graphics. Hold the G 

key and click on the Protected 

Graphic to convert it. Hot keys 

are not case sensitive. 



Moving a Project that Contains Protected Graphics 

If you want to move your Project file from one disk or computer to another, that you must take 

special precautions if you are using Protected Graphics. 

Since a Protected Graphic’s file is not embedded in the Web Studio Project file, you must be sure 

to move the files along with your Project file. It is best to keep your Protected Graphic’s files in a 

folder for each site so that you can simply move the Project file and the Protected Graphic’s folder 

together. 

If you fail to move the graphic files to the new location of the Project file, then Web Studio will 

notify you when it builds your site. This occurs during a Preview or when you are saving a page or 

website to the internet or to a disk. 

Working with the Object Properties Dialog 

General section 

 

Object Info.  This is the numeric identifier of the object.  If you choose to use custom HTML 

via the HTML Object, then you can refer to these ID's to manipulate the object.   
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Position.  This displays the numeric location of the object on the page.  You can check the box 

to Lock Object Position and you can numerically change the position by changing the number 

values. 

Size.  This displays the pixel size of the object. You can change the size of the object 

numerically and you can choose to Lock Object Size by checking the box. 

Proportional Resizing.  Check this box before you change the size in order to keep the 

original proportions of the object.  

Resample Graphic.  Check this box if you want to Web Studio to resample the graphic 

object when it is resized. This will help the resized graphic look better. 

 

Link section 

 

Link URL.  This reveals the URL (or web address) of the link that has been applied to the 

object. 

Add/Edit Link.  This option displays the Add/Edit Link dialog. You can change the link’s 

name, description, and URL. You can also program the link to open in a new window when it is 

clicked on. 

Delete Link.  Click this check box to delete the link from the object. The link is deleted when 

you click OK. 

 

 



Graphic section 

 

Original Size.  This shows the original size of the object in pixels. You can check Restore 

Original Size after resizing. 

Restore Original Size.  Check this and then click OK in order to restore the original size after 

resizing.  

Color.  Choose a color that you want to be transparent in an object.  

JPEG (or GIF) Graphic Compression.  Choose the amount of compression to apply when 

the object is on the web. There are 9 quality levels. The default level is Q2, which provides 

compression without loss of visual quality. Preview the page to check the quality of the 

compression. Click Page > Preview > Preview Page or another Preview Page command. 

 

The heading for this section will be GIF to JPEG depending on what type of 

file Web Studio will create for this graphic. 
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Protection on Web.  When Copy Protect is checked, Web Studio puts a transparent image in 

front of the graphic. If someone uses right-click to copy the graphic, a blank image is copied.  

 

Important! It is impossible to copy protect graphics on the web completely. 

Web File Type.  This option allows you to choose a file type for the graphic object. Graphics 

that you add are set to Automatic. This setting allows Web Studio to determine what type of 

graphic should be created based on the properties of the graphic itself. You can choose GIF or 

JPEG, which are the two graphic formats that are supported by the web. Choosing one of these 

will override Web Studio’s automatic choice. The graphic will become your chosen file type, 

even if it is not the optimal format for that object. Choosing the wrong format can result in files 

that are extremely big, or in which the colors look bad. If you choose a file and are not satisfied 

with the result, try the other file type. 

Alternate Text Message.  Fill this in with a short description of the image, such as “My new 

car.” The text will appear in a small pop-up window when visitors hover the mouse over the 

image. In addition, search engines look at this text to help them rank various sites. If visitors 

turn off images in Internet Explorer, then the text will be displayed on the page.   

Notes section 

 

This section provides you with an opportunity to record information about the object that you 

may need to know later. For example, you may want to notate the fonts that you used in a 

merged graphic or the precise color used for a background. The notes are saved with the Project 

files and are only visible within Web Studio. 



Quick Tips for Working with Objects 
 

Command Action 

Select one object Click on the object. 

Select more than one Hold the shift key and click each object. 

Move 1 pixel Select objects. Press arrow keys. 

Move 10 pixels Select objects.  

Hold the shift key while pressing arrow keys. 

Constrain movement 
horizontally or vertically 

Hold the shift key and then drag objects. 

Push objects down the page 
to add space 

Select an object.  

Press the P key.  

Objects under the selected object are pushed down the page. 

Pull objects up the page to 
remove space 

Select an object.  

Press the U key.  

Objects under the selected object are pulled up the page. 

Align, center, make equal Select the first object.  

Hold the shift key and then select the other objects.  

Click the command. 

Objects are aligned, centered, or made equal size to the first object. 

Space horizontally or 
vertically 

Position the top/bottom or left/right object.  

Space the other objects loosely in between.  

Select the objects.  

Click on the command. Objects are spaced evenly across or down. 

Space with 1 pixel between Follow the directions for spacing horizontally/vertically, but hold down 
the ctrl+shift keys before you click the command. 

Space with edges touching Follow space horizontally/vertically directions, but hold down the shift 
key before you click the command. 

Crop Select the object.  

Hold down the C key.  

Drag a side top or bottom selection handle to crop in one direction. 

Drag a corner handle to crop both horizontally and vertically. 

Resize Select the object.  

Drag the top, bottom, or side selection handles to resize in one 
direction.  

Drag the corner handle to crop proportionally.  

Hold the shift key and drag the corner handle to resize in two 
directions. 

 


